diff configure.ac @ 1338:0d4450d66bd1

Added libcddb autoconf dependency
author Calin Crisan ccrisan@gmail.com
date Mon, 23 Jul 2007 01:01:18 +0300
parents 831720848162
children ef07ff837063
line wrap: on
line diff
--- a/configure.ac	Sun Jul 22 20:42:28 2007 +0000
+++ b/configure.ac	Mon Jul 23 01:01:18 2007 +0300
@@ -1137,13 +1137,23 @@
 )
 
 if test "$enable_cdaudio_ng" = "yes"; then
-   PKG_CHECK_MODULES(CDIO, [libcdio >= 0.78.2],
+   PKG_CHECK_MODULES(CDIO, [libcdio >= 0.70],
    [INPUT_PLUGINS="$INPUT_PLUGINS cdaudio-ng"
    CDIO_LIBS=`pkg-config --libs libcdio_cdda`
    CDIO_CFLAGS=`pkg-config --cflags libcdio_cdda`
    AC_SUBST(CDIO_LIBS)
    AC_SUBST(CDIO_CFLAGS)],
-   [AC_MSG_WARN([*** Cannot find libcdio 0.78.2 or newer, cdaudio-ng will not be built ***])
+   [AC_MSG_WARN([*** Cannot find libcdio 0.70 or newer, cdaudio-ng will not be built ***])
+   enable_cdaudio_ng=no]
+)
+
+   PKG_CHECK_MODULES(CDDB, [libcddb >= 1.2.1],
+   [INPUT_PLUGINS="$INPUT_PLUGINS cdaudio-ng"
+   CDDB_LIBS=`pkg-config --libs libcddb`
+   CDDB_CFLAGS=`pkg-config --cflags libcddb`
+   AC_SUBST(CDDB_LIBS)
+   AC_SUBST(CDDB_CFLAGS)],
+   [AC_MSG_WARN([*** Cannot find libcddb 1.2.1 or newer, cdaudio-ng will not be built ***])
    enable_cdaudio_ng=no]
 )
 fi