diff configure.ac @ 2967:165ccb8de035

audlegacy-plugins begins.
author Yoshiki Yazawa <yaz@honeyplanet.jp>
date Mon, 24 Nov 2008 21:42:16 +0900
parents 70b0973e7b70
children 54a5384583da
line wrap: on
line diff
--- a/configure.ac	Fri Oct 17 16:48:31 2008 -0500
+++ b/configure.ac	Mon Nov 24 21:42:16 2008 +0900
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 
-AC_INIT([audacious-plugins], [1.9.0], [bugs+audacious-plugins@atheme.org])
+AC_INIT([audlegacy-plugins], [1.9.0], [bugs+audacious-plugins@atheme.org])
 AC_PREREQ([2.59])
 
 AC_CANONICAL_HOST
@@ -133,9 +133,9 @@
 
 dnl Check for Audacious
 
-PKG_CHECK_MODULES(AUDACIOUS, [audacious >= 1.9.0],
-    [ADD_PC_REQUIRES([audacious >= 1.9.0])],
-    [AC_MSG_ERROR([Cannot find Audacious 1.9.0 or later, have you installed audacious yet?])]
+PKG_CHECK_MODULES(AUDLEGACY, [audlegacy >= 1.9.0],
+    [ADD_PC_REQUIRES([audlegacy >= 1.9.0])],
+    [AC_MSG_ERROR([Cannot find Audlegacy 1.9.0 or later, have you installed audlegacy yet?])]
 )
 
 dnl Check for GTK/GLib/GThread/Pango/DBus
@@ -201,7 +201,7 @@
 
 BUILDSYS_SHARED_LIB
 BUILDSYS_PROG_IMPLIB
-test "x$PROG_IMPLIB_NEEDED" = "xyes" && LIBS="$LIBS -L\${libdir} -laudacious.exe"
+test "x$PROG_IMPLIB_NEEDED" = "xyes" && LIBS="$LIBS -L\${libdir} -laudlegacy.exe"
 
 dnl Ok, first we find out what flags we need to use.
 AC_MSG_CHECKING([for what extension and flags to use for plugin compilation])
@@ -407,7 +407,7 @@
 if test "x$enable_mp3" = "xyes"; then
   AC_MSG_CHECKING(mad.h suitability)
   ac_save_CFLAGS="$CFLAGS"
-  CFLAGS="$CFLAGS $MAD_CFLAGS $AUDACIOUS_CFLAGS"
+  CFLAGS="$CFLAGS $MAD_CFLAGS $AUDLEGACY_CFLAGS"
   AC_TRY_RUN(
       [
           #include <mad.h>
@@ -1265,8 +1265,8 @@
 AM_CONDITIONAL(HAVE_CDROM, test "${ac_cv_header_linux_cdrom_h}" = "yes" || test "${ac_cv_header_sys_cdio_h}" = "yes")
 AM_CONDITIONAL(HAVE_LINUX_JOYSTICK,test "${ac_cv_header_linux_joystick_h}" = "yes")
 
-CFLAGS="$CFLAGS $AUDACIOUS_CFLAGS $DBUS_CFLAGS"
-CXXFLAGS="$CXXFLAGS $AUDACIOUS_CFLAGS $DBUS_CFLAGS"
+CFLAGS="$CFLAGS $AUDLEGACY_CFLAGS $DBUS_CFLAGS"
+CXXFLAGS="$CXXFLAGS $AUDLEGACY_CFLAGS $DBUS_CFLAGS"
 
 AC_MSG_CHECKING(if __ELF__ is defined)
 AC_EGREP_CPP(yes,
@@ -1612,7 +1612,7 @@
 AM_CONDITIONAL(HAVE_SOLARIS, test "x$have_solaris" = xyes)
 AM_CONDITIONAL(HAVE_SUN, test "x$have_sun" = xyes)
 
-plugindir=`pkg-config audacious --variable=plugin_dir`
+plugindir=`pkg-config audlegacy --variable=plugin_dir`
 AC_SUBST(plugindir)
 
 dnl XXX
@@ -1653,7 +1653,7 @@
     AC_DEFINE(DISABLE_USER_PLUGIN_DIR,, [Define to disable per user plugin directory])
 fi
 
-AC_DEFINE(BMP_RCPATH, ".audacious", [Config dir to use])
+AC_DEFINE(BMP_RCPATH, ".audlegacy", [Config dir to use])
 
 AC_SUBST(BEEP_DEFINES)