diff configure.ac @ 135:33d24bd94ccc trunk

[svn] Adds mplayer controls the plugin pack. I don't know crap about configure.ac, so it's totally busted. Also, I used the string "what" in common.c and interface.c. I'm not going to pretend I actually know what I was doing there, but it seems to work despite that.
author asheldon
date Sat, 28 Oct 2006 18:08:06 -0700
parents 46730e83b1e2
children 6b5a52635b3b
line wrap: on
line diff
--- a/configure.ac	Fri Oct 27 13:12:59 2006 -0700
+++ b/configure.ac	Sat Oct 28 18:08:06 2006 -0700
@@ -387,6 +387,19 @@
 	INPUT_PLUGINS="$INPUT_PLUGINS adplug"
 fi
 
+AC_ARG_ENABLE(mplayer,
+    [  --disable-mplayer           disable mplayer plugin. (default=enabled) ],
+    [enable_mplayer=$enableval],
+    [enable_mplayer=yes]
+)
+
+if test "$enable_mplayer" = "yes"; then
+        INPUT_PLUGINS="$INPUT_PLUGINS mplayer"
+        AC_SUBST(LIBNMS_CFLAGS)
+        AC_SUBST(LIBNMS_LIBS)
+        AC_SUBST(LIBNMS_SRC)
+fi
+
 dnl *** Ogg Vorbis
 
 AC_ARG_ENABLE(vorbis,
@@ -1128,6 +1141,7 @@
 echo "  AdLib synthesizer (adplug):             $have_adplug"
 echo "  Apple Lossless Audio Codec (alac):      yes"
 echo "  WavPack 4.31+ (wavpack):                $have_wavpack"
+echo "  Mplayer controls (mplayer):             $enable_mplayer"
 echo
 echo "  General"
 echo "  -------"