diff configure.ac @ 39:3643db656a4f trunk

[svn] Removed the check for socklen_t. This fixes building on NetBSD. curl defined socklen_t anyway, so no need for this. This *MIGHT* break something on some systems (I haven't found one yet, though), so PLEASE report all bugs to me.
author js
date Tue, 19 Sep 2006 07:53:54 -0700
parents e0a8ee3543d3
children f15e55bc0e60
line wrap: on
line diff
--- a/configure.ac	Mon Sep 18 13:43:46 2006 -0700
+++ b/configure.ac	Tue Sep 19 07:53:54 2006 -0700
@@ -123,23 +123,6 @@
 AC_SUBST(TAGLIB_CFLAGS)
 AC_SUBST(TAGLIB_LIBS)
 
-# Check if socklen_t is defined
-
-AC_CACHE_CHECK(for socklen_t, beep_cv_type_socklen_t,
-    [AC_TRY_COMPILE(
-         [#include <sys/types.h>
-          #include <sys/socket.h>],
-         [socklen_t s;],
-         [beep_cv_type_socklen_t=yes],
-         [beep_cv_type_socklen_t=no]
-     )
-    ]
-)
-
-if test "$beep_cv_type_socklen_t" = "no"; then
-    AC_DEFINE(socklen_t, int, [Define to int if the socklen_t type is missing])
-fi
-
 dnl IPv6 support
 dnl ========================
 AC_ARG_ENABLE(ipv6,