diff configure.ac @ 1331:392ca3811f49

Automated merge with ssh://majeru@hg.atheme.org//hg/audacious-plugins
author Cristi Magherusan <majeru@atheme-project.org>
date Sat, 21 Jul 2007 01:52:04 +0300
parents 7573b41fafa4
children 831720848162
line wrap: on
line diff
--- a/configure.ac	Sat Jul 21 01:51:10 2007 +0300
+++ b/configure.ac	Sat Jul 21 01:52:04 2007 +0300
@@ -588,8 +588,7 @@
 )
 
 if test "$enable_flacng" = "yes"; then
-    PKG_CHECK_MODULES(FLAC, [flac >= 1.1.3],
-        [have_flacng=yes],
+    AM_PATH_LIBFLAC([have_flacng=yes], 
         [AC_MSG_WARN([*** Cannot find libFLAC, FLACng will not be built ***])
          have_flacng=no]
     )
@@ -677,25 +676,6 @@
     have_modplug="no"
 fi
 
-dnl *** flac
-AC_ARG_ENABLE( flac,
-[  --enable-flac          enable flac input plugin (default=disabled)],
-[enable_flac=$enableval],
-[enable_flac="no"])
-
-if test "x$enable_flac" = xyes; then
-	if test "x$have_oggvorbis" = xyes; then
-	        INPUT_PLUGINS="$INPUT_PLUGINS flac"
-        	have_flac=yes
-	else
-		AC_MSG_RESULT([*** flac plugin couldn't be enabled due to missing dependencies ***])
-		have_flac=no
-	fi
-else
-        AC_MSG_RESULT([*** flac plugin disabled per user request ***])
-        have_flac=no
-fi
-
 dnl *** Musepack
 
 AC_ARG_ENABLE(musepack,
@@ -1527,7 +1507,6 @@
 echo "    + sndfile extensions:                 $enable_sndfile"
 echo "  Tone Generator:                         yes"
 echo "  Ogg Vorbis (vorbis):                    $have_oggvorbis"
-echo "  Free Lossless Audio Codec (flac):       $have_flac"
 echo "  Free Lossless Audio Codec (flacng):     $have_flacng"
 echo "  Commodore 64 audio (sid):               $have_sidplay"
 echo "  Game music (spc, nsf & gbs):            yes"