diff configure.ac @ 2412:49c27d619ffc

Fix configure.ac to be less retarded.
author William Pitcock <nenolod@atheme.org>
date Mon, 18 Feb 2008 04:42:02 -0600
parents c96c81938c4b
children 7c0cee3d74d9
line wrap: on
line diff
--- a/configure.ac	Mon Feb 18 04:41:02 2008 -0600
+++ b/configure.ac	Mon Feb 18 04:42:02 2008 -0600
@@ -1442,8 +1442,11 @@
 [have_projectm1=yes])
 
 if test "$have_projectm1" = "yes"; then
+	PKG_CHECK_MODULES(GTKGLEXT, [gtkglext-1.0 >= 1.2.0], [have_projectm1="yes"], [have_projectm1="no"])
+fi
+
+if test "$have_projectm1" = "yes"; then
 	PKG_CHECK_MODULES(LIBPROJECTM1, libprojectM >= 1.0, [have_projectm1="yes"], [have_projectm1="no"])
-	PKG_CHECK_MODULES(GTKGLEXT, [gtkglext-1.0 >= 1.2.0], [have_projectm1="yes"], [have_projectm1="no"])
 	if test x$libprjM = xno; then
 	        AC_MSG_WARN([*** libprojectM not found.
 	                        libprojectM is needed to build this package.