diff configure.ac @ 5:54f9e753b511 trunk

[svn] - SDK pathchange fixes - enforce use of SDK - always link against libaudacious
author nenolod
date Mon, 18 Sep 2006 02:22:03 -0700
parents 13389e613d67
children 7cac35581bd0
line wrap: on
line diff
--- a/configure.ac	Mon Sep 18 02:02:50 2006 -0700
+++ b/configure.ac	Mon Sep 18 02:22:03 2006 -0700
@@ -869,22 +869,8 @@
 AM_CONDITIONAL(HAVE_CDROM, test "${ac_cv_header_linux_cdrom_h}" = "yes" || test "${ac_cv_header_sys_cdio_h}" = "yes")
 AM_CONDITIONAL(HAVE_LINUX_JOYSTICK,test "${ac_cv_header_linux_joystick_h}" = "yes")
 
-if test -n "$GCC"
-then
-    CFLAGS="$CFLAGS -Wall -Wno-unused-parameter -Wpointer-arith -finline-functions -ffast-math"
-    case "$CFLAGS" in
-        -g*) ;;
-        *\ -g*) ;;
-        *) CFLAGS="$CFLAGS -fomit-frame-pointer" ;;
-    esac
-    case "$host" in
-        *-*-freebsd*)
-        ;;
-        *)
-        CFLAGS="$CFLAGS -funroll-all-loops"
-        ;;
-    esac
-fi
+CFLAGS="$CFLAGS $AUDACIOUS_CFLAGS"
+LDFLAGS="$LDFLAGS $AUDACIOUS_LIBS"
 
 AC_MSG_CHECKING(if __ELF__ is defined)
 AC_EGREP_CPP(yes,