diff configure.ac @ 2303:5561e63e9133

threw out the WAV plugin in favour of the sndfile plugin
author mf0102 <0102@gmx.at>
date Sat, 12 Jan 2008 18:41:04 +0100
parents cc5e9ec110a4
children ac99d3c3901e
line wrap: on
line diff
--- a/configure.ac	Sat Jan 12 16:35:26 2008 +0100
+++ b/configure.ac	Sat Jan 12 18:41:04 2008 +0100
@@ -120,7 +120,7 @@
 
 dnl These plugins are always built.
 
-INPUT_PLUGINS="tonegen console sexypsf wav cue alac metronom vtx"
+INPUT_PLUGINS="tonegen console sexypsf cue alac metronom vtx"
 OUTPUT_PLUGINS="null"
 EFFECT_PLUGINS="audiocompress ladspa voice_removal sndstretch stereo_plugin echo_plugin"
 GENERAL_PLUGINS="song_change alarm"
@@ -713,11 +713,9 @@
 fi
 
 if test "$enable_sndfile" = "yes"; then
-	WAV_SNDFILE="-sndfile"
+	INPUT_PLUGINS="$INPUT_PLUGINS sndfile"
 fi
 
-AC_SUBST(WAV_SNDFILE)
-
 dnl *** modplug
 
 AC_ARG_ENABLE(modplug,
@@ -1635,8 +1633,7 @@
 echo "    -> dummy backend:                     $enable_amidiplug_dummy"
 echo "  MIDI to WAVE converter (timidity):      $enable_timidity"
 echo "  CD Digital Audio (cdaudio_ng):          $enable_cdaudio_ng"
-echo "  Microsoft WAV (wav):                    yes"
-echo "    + sndfile extensions:                 $enable_sndfile"
+echo "  sndfile extensions:                     $enable_sndfile"
 echo "  Tone Generator:                         yes"
 echo "  Ogg Vorbis (vorbis):                    $have_oggvorbis"
 echo "  Free Lossless Audio Codec (flacng):     $have_flacng"