diff configure.ac @ 1710:5dfa4fc721b0

Add dockalbumart plugin for MacOS. (this could also be ported to GNOME's AWN too.)
author William Pitcock <nenolod@atheme.org>
date Thu, 13 Sep 2007 12:09:38 -0500
parents ec4e8ec829b1
children 892deefba58d
line wrap: on
line diff
--- a/configure.ac	Sun Sep 02 22:18:43 2007 -0500
+++ b/configure.ac	Thu Sep 13 12:09:38 2007 -0500
@@ -280,6 +280,24 @@
 	have_coreaudio=no
 fi
 
+dnl *** Dock Album Art (MacOS)
+
+AC_ARG_ENABLE(dockalbumart,
+    [  --disable-dockalbumart  disable MacOS dock albumart plugin (default=guess)],
+    [enable_dockalbumart=$enableval],
+    [enable_dockalbumart="yes"]
+)
+
+if test "$enable_dockalbumart" = "yes"; then
+	AC_CHECK_HEADERS([Carbon/Carbon.h],
+		[have_dockalbumart=yes
+		 GENERAL_PLUGINS="$GENERAL_PLUGINS dockalbumart"],
+		[have_dockalbumart=no])
+else
+	AC_MSG_RESULT([*** DockAlbumArt plugin disabled per user request ***])
+	have_dockalbumart=no
+fi
+
 dnl *** AltiVec
 
 AC_ARG_ENABLE(altivec,
@@ -1548,6 +1566,7 @@
 echo "  LIRC:                                   $have_lirc"
 echo "  AudioScrobbler Client:                  $scrobbler"
 echo "  Upload to MTP device:                   $have_mtp_up"
+echo "  MacOS Dock Album Art plugin:            $have_dockalbumart"
 echo
 echo "  Effect"
 echo "  ------"