diff configure.ac @ 144:5dfc0e491ad3 trunk

[svn] Null output plugin added; original code by Christian Birchinger <joker -at- gentoo.org>
author kiyoshi
date Mon, 30 Oct 2006 17:40:00 -0800
parents 6d1f65117180
children 03cfb311eafd
line wrap: on
line diff
--- a/configure.ac	Sun Oct 29 12:29:05 2006 -0800
+++ b/configure.ac	Mon Oct 30 17:40:00 2006 -0800
@@ -295,6 +295,22 @@
 	have_coreaudio=no
 fi
 
+dnl *** Null Audio
+
+AC_ARG_ENABLE(null,
+    [  --disable-null          disable Null Audio output plugin (default=enabled)],
+    [enable_null=$enableval],
+    [enable_null="yes"]
+)
+
+if test "$enable_null" = "yes"; then
+	have_null=yes
+	OUTPUT_PLUGINS="$OUTPUT_PLUGINS null"
+else
+	AC_MSG_RESULT([*** Null Audio output plugin disabled per user request ***])
+	have_null=no
+fi
+
 dnl *** AltiVec
 
 AC_CHECK_HEADERS(altivec.h,
@@ -1110,6 +1126,7 @@
 echo "  BSD/SUN audio output (sun):             $have_sun"
 echo "  PulseAudio sound server (pulse_audio):  $have_pulse"
 echo "  Mac OS X sound support (CoreAudio):     $have_coreaudio"
+echo "  Null Audio output (null):               $have_null"
 echo
 echo "  Input Plugins"
 echo "  -------------"