diff configure.ac @ 422:5e46b57d1eda trunk

[svn] - added evdev-plug, written-from-scratch plugin that allows to control the player via event devices on linux systems
author giacomo
date Sun, 14 Jan 2007 17:55:24 -0800
parents 37a183b4ce60
children 74b23aec578d
line wrap: on
line diff
--- a/configure.ac	Sun Jan 14 02:35:15 2007 -0800
+++ b/configure.ac	Sun Jan 14 17:55:24 2007 -0800
@@ -354,6 +354,33 @@
 	GENERAL_PLUGINS="$GENERAL_PLUGINS lirc"
 fi
 
+dnl *** EvDev-Plug general plugin (only built on Linux)
+
+AC_ARG_ENABLE(evdevplug,
+    [  --disable-evdevplug     disable Linux evdev plugin (default=enabled)],
+    [enable_evdevplug=$enableval],
+    [enable_evdevplug="yes"]
+)
+
+if test "x$enable_evdevplug" = "xyes"; then
+    case "$target" in
+        *-*-linux*)
+            have_evdevplug="yes"
+        ;;
+        *)
+            AC_MSG_RESULT([*** Linux evdev plugin disabled (host does not run linux) ***])
+            have_evdevplug="no"
+        ;;
+    esac
+else
+    AC_MSG_RESULT([*** Linux evdev plugin disabled per user request ***])
+    have_evdevplug="no"
+fi
+
+if test "x$have_evdevplug" = "xyes"; then
+    GENERAL_PLUGINS="$GENERAL_PLUGINS evdev-plug"
+fi
+
 dnl *** AdPlug requirement (libbinio)
 
 AC_ARG_ENABLE(adplug,
@@ -1148,6 +1175,7 @@
 echo "  -------"
 echo "  Alarm:                                  yes"
 echo "  Song Change:                            yes"
+echo "  Control via event device (evdev-plug):  $have_evdevplug"
 echo "  LIRC:                                   $have_lirc"
 echo "  AudioScrobbler Client:                  $scrobbler"
 echo