diff configure.ac @ 232:6c78d6d3cdb7 trunk

[svn] - put musepack support back
author nenolod
date Tue, 07 Nov 2006 00:07:11 -0800
parents 49136c75b018
children a60da24269dc
line wrap: on
line diff
--- a/configure.ac	Mon Nov 06 23:19:42 2006 -0800
+++ b/configure.ac	Tue Nov 07 00:07:11 2006 -0800
@@ -498,6 +498,27 @@
 	INPUT_PLUGINS="$INPUT_PLUGINS flac$FLAC_VERSION"
 fi
 
+dnl *** Musepack
+
+AC_ARG_ENABLE(musepack,
+    [  --disable-musepack      disable musepack input plugin (default=enabled)],
+    [enable_musepack=$enableval],
+    [enable_musepack="yes"]
+)
+
+if test "$enable_musepack" = "yes"; then
+    AC_CHECK_HEADERS(mpcdec/config_types.h,,
+        enable_musepack=no
+    )
+else
+    AC_MSG_RESULT([*** Musepack plugin disabled per user request ***])
+    enable_musepack=no
+fi
+
+if test "$enable_musepack" = "yes"; then
+        INPUT_PLUGINS="$INPUT_PLUGINS musepack"
+fi
+
 dnl *** WMA
 
 AC_ARG_ENABLE(wma,
@@ -1082,6 +1103,7 @@
 echo "  AdLib synthesizer (adplug):             $have_adplug"
 echo "  Apple Lossless Audio Codec (alac):      yes"
 echo "  WavPack 4.31+ (wavpack):                $have_wavpack"
+echo "  Musepack support (musepack):            $enable_musepack"
 echo
 echo "  General"
 echo "  -------"