diff configure.ac @ 2644:6fd8ca4b7b17

add bluetooth plugin
author Paula Stanciu <paula.stanciu@gmail.com>
date Sat, 17 May 2008 21:22:49 +0300
parents 27630085a2c7
children c1258ae018ee
line wrap: on
line diff
--- a/configure.ac	Tue May 13 20:10:57 2008 +0200
+++ b/configure.ac	Sat May 17 21:22:49 2008 +0300
@@ -1372,6 +1372,26 @@
 AC_SUBST(MTP_LIBS)
 AC_SUBST(MTP_CFLAGS)
 
+dnl *** Bluetooth audio suport 
+
+AC_ARG_ENABLE(bluetooth,
+[  --disable-bluetooth           disable bluetooth audio support. (default=enabled)],
+[have_bluetooth=$enableval],
+[have_bluetooth=yes])
+
+if test "x$have_bluetooth" = "xyes"; then
+    have_bluetooth=yes
+    PKG_CHECK_MODULES(BLUEZ, [bluez >= 2.22],
+    [GENERAL_PLUGINS="$GENERAL_PLUGINS bluetooth" ], [have_bluetooth="no"])
+    BLUEZ_LIBS=`pkg-config --libs bluez`
+    BLUEZ_CFLAGS=`pkg-config --cflags bluez`
+else
+    have_bluetooth=no
+    AC_MSG_RESULT([*** bluetooth audio suport plugin disabled by request ***])
+fi
+AC_SUBST(BLUEZ_LIBS)
+AC_SUBST(BLUEZ_CFLAGS)
+
 dnl *** libparanormal checks
 
 AC_ARG_ENABLE(paranormal,
@@ -1687,6 +1707,7 @@
 echo "  LIRC:                                   $have_lirc"
 echo "  AudioScrobbler Client:                  $scrobbler"
 echo "  Upload to MTP device:                   $have_mtp_up"
+echo "  Bluetooth audio suport:                 $have_bluetooth"
 echo "  MacOS Dock Album Art plugin:            $have_dockalbumart"
 echo
 echo "  Effect"