diff configure.ac @ 560:7b4b37819c9d trunk

[svn] made null always build
author kiyoshi
date Sun, 28 Jan 2007 17:41:50 -0800
parents fe2c60ca8c98
children 550c9e382cf8
line wrap: on
line diff
--- a/configure.ac	Sun Jan 28 17:02:41 2007 -0800
+++ b/configure.ac	Sun Jan 28 17:41:50 2007 -0800
@@ -94,7 +94,7 @@
 dnl These plugins are always built.
 
 INPUT_PLUGINS="tonegen console sexypsf wav cue alac metronom"
-OUTPUT_PLUGINS="disk_writer"
+OUTPUT_PLUGINS="disk_writer null"
 EFFECT_PLUGINS="audiocompress ladspa voice_removal stereo_plugin echo_plugin"
 GENERAL_PLUGINS="song_change alarm"
 VISUALIZATION_PLUGINS="blur_scope spectrum"
@@ -277,22 +277,6 @@
 	have_coreaudio=no
 fi
 
-dnl *** Null Audio
-
-AC_ARG_ENABLE(null,
-    [  --disable-null          disable Null Audio output plugin (default=enabled)],
-    [enable_null=$enableval],
-    [enable_null="yes"]
-)
-
-if test "$enable_null" = "yes"; then
-	have_null=yes
-	OUTPUT_PLUGINS="$OUTPUT_PLUGINS null"
-else
-	AC_MSG_RESULT([*** Null Audio output plugin disabled per user request ***])
-	have_null=no
-fi
-
 dnl *** AltiVec
 
 AC_CHECK_HEADERS(altivec.h,
@@ -1180,7 +1164,7 @@
 echo "  BSD/SUN audio output (sun):             $have_sun"
 echo "  PulseAudio sound server (pulse_audio):  $have_pulse"
 echo "  Mac OS X sound support (CoreAudio):     $have_coreaudio"
-echo "  Null Audio output (null):               $have_null"
+echo "  Null Audio output (null):               yes"
 echo
 echo "  Input Plugins"
 echo "  -------------"