diff configure.ac @ 922:7e14701aef54 trunk

[svn] - replace random number generator in dithering code with SIMD-oriented Fast Mersenne Twister (SFMT). it reduces CPU load on SSE2 or AltiVec capable platform.
author yaz
date Sun, 08 Apr 2007 21:30:22 -0700
parents 8b4b381b4399
children 053baea2cbef
line wrap: on
line diff
--- a/configure.ac	Sat Apr 07 11:06:36 2007 -0700
+++ b/configure.ac	Sun Apr 08 21:30:22 2007 -0700
@@ -250,11 +250,31 @@
     [AC_DEFINE(HAVE_ALTIVEC, 1, [Define to 1 if your system has AltiVec.])
      AC_DEFINE(HAVE_ALTIVEC_H, 1, [Define to 1 if your system has an altivec.h file.])
      AC_DEFINE(ARCH_POWERPC, 1, [Define to 1 if your system is a PowerPC.])
-     DCT64=dct64_altivec.c],
+     DCT64=dct64_altivec.c
+     SIMD_CFLAGS=-maltivec
+     AC_SUBST(SIMD_CFLAGS)],
     [DCT64=dct64.c]
 )    
 AC_SUBST(DCT64)
 
+dnl *** SSE2
+
+AC_LANG(C)
+AC_LANG_CONFTEST([AC_LANG_SOURCE([[#include <xmmintrin.h>
+int main(){
+#if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 2)
+return 0;
+#else
+#error no vector builtins
+#endif
+}]])])
+gcc -E -dD -msse2 -o - conftest.c
+if test $? = 0 ; then
+   AC_DEFINE(HAVE_SSE2, 1, [Define to 1 if your system has SSE2])
+   SIMD_CFLAGS=-msse2
+   AC_SUBST(SIMD_CFLAGS)
+fi
+
 dnl *** MP3
 
 AC_ARG_ENABLE(mp3,