diff configure.ac @ 1718:892deefba58d

- Add neon HTTP transport plugin sources
author Ralf Ertzinger <ralf@skytale.net>
date Mon, 17 Sep 2007 21:40:37 +0200
parents 5dfa4fc721b0
children 48b4c7d504f7
line wrap: on
line diff
--- a/configure.ac	Mon Sep 17 09:05:53 2007 -0500
+++ b/configure.ac	Mon Sep 17 21:40:37 2007 +0200
@@ -1253,6 +1253,24 @@
 
 dnl *** End of Scrobbler checks ***
 
+dnl *** neon http plugin ***
+
+AC_ARG_ENABLE(neon,
+[  --enable-neon           enable neon support (experimental).  (default=disabled)],
+[have_neon=$enableval],
+[have_neon=no])
+
+if test "x$have_neon" = "xyes"; then
+    PKG_CHECK_MODULES(NEON, [neon >= 0.27], [TRANSPORT_PLUGINS="$TRANSPORT_PLUGINS neon" ], [have_neon="no"])
+    NEON_LIBS=`pkg-config --libs neon`
+    NEON_CFLAGS=`pkg-config --cflags neon`
+else
+    have_neon=no
+fi
+AC_SUBST(NEON_LIBS)
+AC_SUBST(NEON_CLFAGS)
+
+
 dnl *** MMS
 
 AC_ARG_ENABLE(mms,