diff configure.ac @ 2674:b84f2aca1675

Fixed js's commit, and few other things.
author Matti Hamalainen <ccr@tnsp.org>
date Sun, 01 Jun 2008 01:02:11 +0300
parents 9a84004b61ad
children 5719fca5b7a4 5df83337516f
line wrap: on
line diff
--- a/configure.ac	Sat May 31 23:59:24 2008 +0200
+++ b/configure.ac	Sun Jun 01 01:02:11 2008 +0300
@@ -1328,14 +1328,12 @@
 
 if test "x$have_neon" = "xyes"; then
     PKG_CHECK_MODULES(NEON, [neon >= 0.26], [TRANSPORT_PLUGINS="$TRANSPORT_PLUGINS neon" ], [have_neon="no"])
-    NEON_LIBS=`pkg-config --libs neon`
-    NEON_CFLAGS=`pkg-config --cflags neon`
-    AC_CHECK_LIB(neon, ne_set_connect_timeout, [AC_DEFINE(HAVE_NE_SET_CONNECT_TIMEOUT, 1, [Whether we have ne_set_connect_timeout]), [], $NEON_LIBS)
+    AC_CHECK_LIB([neon], [ne_set_connect_timeout], [AC_DEFINE(HAVE_NE_SET_CONNECT_TIMEOUT, 1, [Whether we have ne_set_connect_timeout])], [], [$NEON_LIBS])
 else
-    have_neon=no
+    have_neon="no"
 fi
-AC_SUBST(NEON_LIBS)
-AC_SUBST(NEON_CLFAGS)
+AC_SUBST([NEON_LIBS])
+AC_SUBST([NEON_CFLAGS])
 
 
 dnl *** MMS