diff configure.ac @ 2763:bbde87558ec7

integrated streambrowser into the main buildsystem
author Calin Crisan ccrisan@gmail.com
date Thu, 03 Jul 2008 02:02:19 +0300
parents 5a0f5e9af5ef
children 7fc2c317d190
line wrap: on
line diff
--- a/configure.ac	Wed Jul 02 21:27:56 2008 +0200
+++ b/configure.ac	Thu Jul 03 02:02:19 2008 +0300
@@ -1237,6 +1237,16 @@
 )
 fi
 
+AC_ARG_ENABLE(streambrowser,
+    [  --disable-streambrowser       disable streambrowser general plugin (default=enabled) ],
+    [enable_streambrowser=$enableval],
+    [enable_streambrowser=yes]
+)
+
+if test "$enable_streambrowser" = "yes"; then
+   GENERAL_PLUGINS="$GENERAL_PLUGINS streambrowser"
+fi
+
 AM_CONDITIONAL(HAVE_CDROM, test "${ac_cv_header_linux_cdrom_h}" = "yes" || test "${ac_cv_header_sys_cdio_h}" = "yes")
 AM_CONDITIONAL(HAVE_LINUX_JOYSTICK,test "${ac_cv_header_linux_joystick_h}" = "yes")
 
@@ -1712,6 +1722,7 @@
 echo "  Upload to MTP device:                   $have_mtp_up"
 echo "  Bluetooth audio suport:                 $have_bluetooth"
 echo "  MacOS Dock Album Art plugin:            $have_dockalbumart"
+echo "  Streambrowser:                          $enable_streambrowser"
 echo
 echo "  Effect"
 echo "  ------"