diff configure.ac @ 728:c26dc360a03e trunk

[svn] - no vorbis? disallow flac too.
author nenolod
date Sun, 25 Feb 2007 06:01:46 -0800
parents a467a9e84295
children 1959cac04fb8
line wrap: on
line diff
--- a/configure.ac	Sun Feb 25 05:27:51 2007 -0800
+++ b/configure.ac	Sun Feb 25 06:01:46 2007 -0800
@@ -510,8 +510,13 @@
                 enable_flac="yes")
 
 if test "x$enable_flac" = xyes; then
-        INPUT_PLUGINS="$INPUT_PLUGINS flac"
-        have_flac=yes
+	if test "x$have_oggvorbis" = xyes; then
+	        INPUT_PLUGINS="$INPUT_PLUGINS flac"
+        	have_flac=yes
+	else
+		AC_MSG_RESULT([*** flac plugin couldn't be enabled due to missing dependencies ***])
+		have_flac=no
+	fi
 else
         AC_MSG_RESULT([*** flac plugin disabled per user request ***])
         have_flac=no