diff configure.ac @ 1190:ed2d7787779e trunk

more warning elimination.
author Yoshiki Yazawa <yaz@cc.rim.or.jp>
date Thu, 21 Jun 2007 17:33:00 +0900
parents 5896bd827cbc
children e49e02828f85
line wrap: on
line diff
--- a/configure.ac	Wed Jun 20 22:27:48 2007 +0300
+++ b/configure.ac	Thu Jun 21 17:33:00 2007 +0900
@@ -1306,7 +1306,7 @@
    [have_vorbisenc=yes], [have_vorbisenc=no])
    if test "$have_vorbisenc" = yes; then
       AC_DEFINE(FILEWRITER_VORBIS, 1, [Define if Vorbis output part should be built])
-      FILEWRITER_LIBS="$FILEWRITER_LIBS  -lvorbisenc"
+      FILEWRITER_LIBS="$FILEWRITER_LIBS  `pkg-config --libs vorbisenc`"
    fi
 fi
 
@@ -1322,7 +1322,7 @@
    )
    if test "$have_writer_flac" = yes; then
       AC_DEFINE(FILEWRITER_FLAC, 1, [Define if FLAC output part should be built])
-	  FILEWRITER_LIBS="$FILEWRITER_LIBS  -lFLAC"
+	  FILEWRITER_LIBS="$FILEWRITER_LIBS  `pkg-config --libs flac`"
    fi
 fi