diff configure.ac @ 1973:f86cb7fc1d4f

Add -pipe -Wall if gcc and fix a few warnings.
author Jonathan Schleifer <js@h3c.de>
date Wed, 03 Oct 2007 17:24:59 +0200
parents 266f1bf0d5fc
children 89a445c53318
line wrap: on
line diff
--- a/configure.ac	Wed Oct 03 16:15:00 2007 +0200
+++ b/configure.ac	Wed Oct 03 17:24:59 2007 +0200
@@ -41,6 +41,10 @@
 AC_ISC_POSIX
 AC_C_BIGENDIAN
 
+if test x"$GCC" = x"yes"; then
+	CFLAGS="$CFLAGS -pipe -Wall"
+	CXXFLAGS="$CXXFLAGS -pipe -Wall"
+fi
 
 dnl Locate a program and check that its version is acceptable.
 dnl AC_PROG_CHECK_VER(var, namelist, version-switch,