diff configure.ac @ 1418:0d6d938bc936 trunk

[svn] - work around a possible autoconf bug causing datadir to be blank
author nenolod
date Tue, 18 Jul 2006 08:49:50 -0700
parents 8accd819fa5e
children 25110f034157
line wrap: on
line diff
--- a/configure.ac	Sun Jul 16 10:09:29 2006 -0700
+++ b/configure.ac	Tue Jul 18 08:49:50 2006 -0700
@@ -917,6 +917,11 @@
 AC_SUBST(VISUALIZATION_PLUGIN_DIR)
 AC_SUBST(pluginsubs)
 
+dnl XXX Work around an autoconf bug.
+if [ ! $datadir ]; then
+	datadir=${prefix}/share
+fi
+
 localedir=$datadir/locale
 AC_SUBST(localedir)