diff configure.ac @ 3433:2f96a5ab1916 trunk

--enable-pch to use precompiled headers, does not properly work
author William Pitcock <nenolod@atheme.org>
date Fri, 07 Sep 2007 00:30:58 -0500
parents 91c27073aa13
children 6d385ae0e97a
line wrap: on
line diff
--- a/configure.ac	Fri Sep 07 00:20:55 2007 -0500
+++ b/configure.ac	Fri Sep 07 00:30:58 2007 -0500
@@ -40,11 +40,7 @@
 AC_ISC_POSIX
 AC_C_BIGENDIAN
 
-dnl If we have GCC, build pre-compiled headers to speed compilation times.
-PCH=""
 test x"$GCC" = x"yes" && CFLAGS="$CFLAGS -Wall -pipe"
-test x"$GCC" = x"yes" && PCH="pch"
-AC_SUBST(PCH)
 
 dnl Check for assembler
 
@@ -145,6 +141,16 @@
 AM_CONDITIONAL(USE_IPV6,test "x$enable_ipv6" = xyes)
 AC_SUBST(USE_IPV6)
 
+dnl PCH support
+dnl ========================
+AC_ARG_ENABLE(pch,
+	[  --enable-pch                   use GCC precompiled headers (experimental) (default=no)],
+			enable_pch=$enableval, enable_pch=no)
+if test "x$enable_pch" = xyes; then
+   PCH="pch"
+fi
+AC_SUBST(PCH)
+
 dnl rpath stuff
 dnl ========================
 AC_ARG_ENABLE(rpath,