diff configure.ac @ 1703:409444cb0605 trunk

[svn] - only build cdaudio plugin if we support DAE
author nenolod
date Fri, 15 Sep 2006 16:48:51 -0700
parents 021f87117ac9
children ffa7b9168190
line wrap: on
line diff
--- a/configure.ac	Fri Sep 15 16:36:30 2006 -0700
+++ b/configure.ac	Fri Sep 15 16:48:51 2006 -0700
@@ -115,7 +115,7 @@
 
 dnl These plugins are always built.
 
-INPUT_PLUGINS="cdaudio tonegen console sexypsf wav cue"
+INPUT_PLUGINS="tonegen console sexypsf wav cue"
 OUTPUT_PLUGINS="disk_writer"
 EFFECT_PLUGINS="audiocompress ladspa voice_removal"
 GENERAL_PLUGINS="song_change"
@@ -896,6 +896,7 @@
 
 if test "${ac_cv_header_linux_cdrom_h}" = "yes" || test "${ac_cv_header_sys_cdio_h}" = "yes"
 then
+    INPUT_PLUGINS="cdaudio $INPUT_PLUGINS"
     case "$host" in
         *-*-sunos* | *-*-solaris* | *-*-linux*)
             AC_DEFINE(BEEP_CDROM_SOLARIS,, [Define if cdrom access is in Solaris style])