diff configure.ac @ 1747:44ed31f63ee4 trunk

[svn] - add back a test for libxml2, that way we'll still use xspf as default if available
author nenolod
date Mon, 18 Sep 2006 13:06:15 -0700
parents 40e2d429a1f1
children 96209f062dc3
line wrap: on
line diff
--- a/configure.ac	Mon Sep 18 13:03:22 2006 -0700
+++ b/configure.ac	Mon Sep 18 13:06:15 2006 -0700
@@ -366,6 +366,19 @@
 
 AC_SUBST(BEEP_DEFINES)
 
+AC_ARG_ENABLE(xspf,
+[  --disable-xspf          disable XSPF support. (default=enabled)],
+[have_xspf=$enableval], [have_xspf=yes])
+
+AM_PATH_XML2(2.0.0, , [
+       AC_MSG_WARN([*** libxml2 is not installed. Paranormal nor XSPF support will not be built. ***])
+       have_xspf="no"
+])
+
+if test "$have_xspf" = "yes"; then
+       AC_DEFINE(HAVE_XSPF_PLAYLIST, 1, [Define if XSPF playlists are available.])
+fi
+
 AC_SUBST(beepdir)
 AC_SUBST(plugindir)