diff configure.ac @ 4655:60910362ecf2

More simplifications of the configure code.
author Matti Hamalainen <ccr@tnsp.org>
date Mon, 16 Jun 2008 14:50:16 +0300
parents de5d2e65cc32
children 52d8b00cfe13
line wrap: on
line diff
--- a/configure.ac	Mon Jun 16 14:15:36 2008 +0300
+++ b/configure.ac	Mon Jun 16 14:50:16 2008 +0300
@@ -76,7 +76,7 @@
 AC_PATH_PROG([AUDACIOUS_PATH], [audacious], [no])
 
 AUD_ARG_ENABLE([user-plugin-dir], [yes],
-[Disable per-user plugin dir (def: enabled)])
+[Disable per-user plugin dir])
 
 if test "x$enable_user_plugin_dir" = "xno"; then
     AC_DEFINE([DISABLE_USER_PLUGIN_DIR], 1, [Define to disable per user plugin directory])
@@ -87,7 +87,7 @@
 dnl Chardet support
 dnl ===============
 AUD_ARG_ENABLE([chardet], [yes],
-[Disable charset detection support (def: enabled)],
+[Disable charset detection support],
 [
     AC_DEFINE([USE_CHARDET], 1, [Define if character set detection enabled])
     AC_CHECK_LIB([udet_c], [detectCharset], [
@@ -103,7 +103,7 @@
 dnl D-Bus support
 dnl =============
 AUD_ARG_ENABLE([dbus], [yes],
-[Enable D-Bus support (def: enabled)],
+[Enable D-Bus support],
 [
     PKG_CHECK_MODULES([DBUS], [dbus-1 >= 0.60 dbus-glib-1 >= 0.60 gthread-2.0],
         [enable_dbus=yes],
@@ -134,7 +134,7 @@
 dnl libsamplerate support
 dnl =====================
 AUD_ARG_ENABLE([samplerate], [no],
-[Enable libsamplerate support (def: disabled)],
+[Enable libsamplerate support],
 [
     AUD_CHECK_MODULE([SAMPLERATE], [samplerate],, [libsamplerate])
     aud_save_LIBS="$LIBS"
@@ -155,7 +155,7 @@
 dnl xspf playlist support
 dnl =====================
 AUD_ARG_ENABLE([xspf], [yes],
-[Disable XSPF support (def: enabled)],
+[Disable XSPF support],
 [
     AM_PATH_XML2([2.0.0],, [
        AC_MSG_WARN([*** libxml2 is not installed. XSPF playlist support will not be built. ***])
@@ -209,7 +209,7 @@
 AC_DEFINE_UNQUOTED([AUDACIOUS_DESKTOP_FILE], "${desktop_file}", [Location of the desktop file])
 
 AUD_ARG_ENABLE([sm], [yes],
-[Disable session management (def: enabled)],
+[Disable session management],
 [
     PKG_CHECK_MODULES([SM], [sm >= 1.0], [
         AC_DEFINE([USE_EGGSM], 1, [Define if session management should be used.])