diff configure.ac @ 2538:719e0898ff3c trunk

[svn] - Patch to use libsamplerate for high-quality interpolated upsampling, similar to what foobar2000 can do. Patch by Teru KAMOGASHIRA.
author nenolod
date Sat, 17 Feb 2007 02:19:35 -0800
parents 97a305e550cf
children 6b2743b54fd7
line wrap: on
line diff
--- a/configure.ac	Sat Feb 17 01:54:30 2007 -0800
+++ b/configure.ac	Sat Feb 17 02:19:35 2007 -0800
@@ -204,6 +204,20 @@
 AC_SUBST(CHARDET_LIBS)
 AC_SUBST(SUBDIR_GUESS)
 
+dnl libsamplerate support
+dnl ========================
+AC_ARG_ENABLE(samplerate,
+  [  --enable-samplerate          enable libsamplerate support (default=no)],
+  [cv_samplerate="$enable_samplerate"], [cv_samplerate="no"])
+if test "x$cv_samplerate" = "xyes"; then
+   AC_DEFINE(USE_SRC, 1, [Define if libsamplerate enabled] )
+   PKG_CHECK_MODULES(samplerate, samplerate)
+   AC_SUBST(USE_SRC)
+   AC_SUBST(samplerate_CFLAGS)
+   AC_SUBST(samplerate_LIBS)
+   AC_CHECK_LIB(samplerate, src_process,,AC_MSG_ERROR([*** Unable to find libsamplerate library!]))
+fi
+
 dnl regex support (gnu/oniguruma/pcre)
 dnl ========================
 REGEX_LIBS=