diff configure.ac @ 2535:97a305e550cf trunk

[svn] - make libmcs a forced requirement - remove legacy configdb engines - remove RcFile class (use g_keyfile instead)
author nenolod
date Sat, 17 Feb 2007 00:59:50 -0800
parents 10692383c103
children 719e0898ff3c
line wrap: on
line diff
--- a/configure.ac	Fri Feb 16 18:28:07 2007 -0800
+++ b/configure.ac	Sat Feb 17 00:59:50 2007 -0800
@@ -276,21 +276,13 @@
     [enable_mcs="no"]
 )
 
-if test "$enable_mcs" = "yes"; then
-    PKG_CHECK_MODULES(LIBMCS, [libmcs >= 0.1],
-        [
-         AC_DEFINE(HAVE_MCS, , [Define if building with libmcs support])
-         ADD_PC_REQUIRES([libmcs >= 0.1])
-        ],
-        [AC_MSG_ERROR([Cannot find libmcs])]
-    )
-fi
-
-if test "$enable_mcs" = "yes"; then
-	CONFIGDB_BACKEND="libmcs"
-fi
-
-AC_SUBST(CONFIGDB_BACKEND)
+PKG_CHECK_MODULES(LIBMCS, [libmcs >= 0.1],
+   [
+      AC_DEFINE(HAVE_MCS, , [Define if building with libmcs support])
+      ADD_PC_REQUIRES([libmcs >= 0.1])
+   ],
+   [AC_MSG_ERROR([Cannot find libmcs])]
+)
 
 AC_CHECK_HEADERS(unistd.h)
 AC_CHECK_HEADERS(fcntl.h)