diff audacious/Makefile.am @ 0:cb178e5ad177 trunk

[svn] Import audacious source.
author nenolod
date Mon, 24 Oct 2005 03:06:47 -0700
parents
children ccd034857702
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/audacious/Makefile.am	Mon Oct 24 03:06:47 2005 -0700
@@ -0,0 +1,94 @@
+SUBDIRS = glade images
+
+beepincludedir = $(includedir)/audacious
+
+bin_PROGRAMS = audacious
+
+audacious_LDFLAGS = -export-dynamic
+audacious_LDADD = \
+	$(X_LIBS) $(X_PRE_LIBS) -lX11 $(X_EXTRA_LIBS) \
+	$(GTK_LIBS)      \
+	$(LIBGLADE_LIBS) \
+	$(LTLIBINTL)     \
+	$(top_builddir)/libaudacious/libaudacious.la
+
+audacious_CFLAGS = \
+	$(X_CFLAGS)        \
+	$(GTK_CFLAGS)      \
+	$(LIBGLADE_CFLAGS) \
+	$(BEEP_DEFINES)    \
+	$(ARCH_DEFINES)    \
+	-I$(top_srcdir)    \
+	-I$(top_srcdir)/intl
+
+audacious_SOURCES = \
+	skin.c skin.h \
+	util.c util.h \
+	output.c output.h \
+	fft.c fft.h \
+	input.c input.h \
+	effect.c effect.h \
+	general.c general.h \
+	visualization.c visualization.h \
+	fullscreen.c fullscreen.h \
+	pluginenum.c pluginenum.h \
+	playlist.c playlist.h \
+	controlsocket.c controlsocket.h \
+	dock.c dock.h \
+	widget.c widget.h \
+	sbutton.c sbutton.h \
+	pbutton.c pbutton.h \
+	tbutton.c tbutton.h \
+	textbox.c textbox.h \
+	menurow.c menurow.h \
+	hslider.c hslider.h \
+	monostereo.c monostereo.h \
+	vis.c vis.h \
+	svis.c svis.h \
+	number.c number.h \
+	playback.c playback.h \
+	playstatus.c playstatus.h \
+	playlist_list.c playlist_list.h \
+	playlist_slider.c playlist_slider.h \
+	playlist_popup.c playlist_popup.h \
+	eq_graph.c eq_graph.h \
+	eq_slider.c eq_slider.h \
+	main.c main.h \
+	logger.c logger.h \
+	xml_document.c xml_document.h \
+	mainwin.c mainwin.h \
+	skinwin.c skinwin.h \
+	prefswin.c prefswin.h \
+	playlistwin.c playlistwin.h \
+	equalizer.c equalizer.h \
+	glade.c glade.h \
+	hints.c hints.h \
+	about.c about.h \
+	plugin.h \
+	softvolume.c softvolume.h \
+	getopt.c getopt1.c getopt.h \
+	urldecode.c urldecode.h \
+	dnd.h \
+	debug.h \
+	mkdtemp.c \
+	pixmaps.h \
+	iir.c iir.h \
+	na.xpm beep_logo.xpm
+
+beepinclude_HEADERS = plugin.h fullscreen.h
+
+desktop_DATA = audacious.desktop
+desktopdir = $(datadir)/applications
+
+
+BUILT_SOURCES = pixmaps.h
+
+embedded_icons = \
+	info.png playlist.png play.png
+
+
+EXTRA_DIST = \
+	$(embedded_icons) build.list
+
+pixmaps.h: $(embedded_icons)
+	gdk-pixbuf-csource --stream --build-list `cat build.list` > pixmaps.h