diff libaudacious/Makefile.am @ 0:cb178e5ad177 trunk

[svn] Import audacious source.
author nenolod
date Mon, 24 Oct 2005 03:06:47 -0700
parents
children b65fe3b68300
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/libaudacious/Makefile.am	Mon Oct 24 03:06:47 2005 -0700
@@ -0,0 +1,51 @@
+ACLOCAL_AMFLAGS = -I ../m4
+AUTOMAKE_OPTIONS = foreign
+
+beepincludedir = $(includedir)/audacious
+
+lib_LTLIBRARIES = libaudacious.la
+
+libaudacious_la_LDFLAGS = -export-dynamic -version-info $(LIBBEEP_MAJOR_VERSION):$(LIBBEEP_MINOR_VERSION):$(LIBBEEP_MICRO_VERSION)
+
+libaudacious_la_LIBADD = \
+	$(GTK_LIBS)      \
+	$(GCONF_LIBS)    \
+	$(GNOMEVFS_LIBS)
+
+INCLUDES = \
+	$(GTK_CFLAGS)        \
+	$(GCONF_CFLAGS)      \
+	$(GNOMEVFS_CFLAGS)   \
+	-I$(top_srcdir)      \
+	-I$(top_srcdir)/intl
+
+if HAVE_GCONF
+    CONF_SRC = configdb_gconf.c
+else
+    CONF_SRC = configdb_rcfile.c
+endif
+
+if HAVE_GNOME_VFS
+    VFS_SRC = vfs_gnome.c
+else
+    VFS_SRC = vfs_stdio.c
+endif
+
+libaudacious_la_SOURCES = \
+	$(CONF_SRC) configdb.h \
+	rcfile.c rcfile.h \
+	$(VFS_SRC) vfs.h \
+	configfile.c \
+	beepctrl.c beepctrl.h \
+	dirbrowser.c dirbrowser.h \
+	util.c util.h \
+	formatter.c formatter.h \
+	titlestring.c titlestring.h \
+	xentry.c xentry.h \
+	xconvert.c xconvert.h
+
+beepinclude_HEADERS = \
+	vfs.h rcfile.h configdb.h \
+	configfile.h \
+	beepctrl.h dirbrowser.h util.h \
+	formatter.h titlestring.h