diff configure.ac @ 1743:d22d28e52b58 trunk

[svn] - remove plugins from the core distribution - remove stupid ricer CFLAGS addition (Plugins are now at: svn co http://svn.atheme.org/audacious-plugins/trunk -- have a nice day)
author nenolod
date Mon, 18 Sep 2006 02:51:11 -0700
parents 7a5e936e4b7f
children 225d3ee03de8
line wrap: on
line diff
--- a/configure.ac	Mon Sep 18 02:34:43 2006 -0700
+++ b/configure.ac	Mon Sep 18 02:51:11 2006 -0700
@@ -113,28 +113,6 @@
     ]
 )
 
-dnl These plugins are always built.
-
-INPUT_PLUGINS="tonegen console sexypsf wav cue"
-OUTPUT_PLUGINS="disk_writer"
-EFFECT_PLUGINS="audiocompress ladspa voice_removal"
-GENERAL_PLUGINS="song_change"
-VISUALIZATION_PLUGINS="blur_scope"
-CONTAINER_PLUGINS="m3u pls"
-
-dnl Option to change equalizer to the old XMMS one which only works with the mpg123
-dnl plugin (or rather, only implemented within the plugin)
-
-AC_ARG_WITH(xmms-eq,
-    [  --with-xmms-eq                 Use old XMMS equalization code.],
-    [use_xmms_eq=$withval],
-    [use_xmms_eq=no]
-)
-
-if test "$use_xmms_eq" = "yes"; then
-   AC_DEFINE(XMMS_EQ, , [Define if building with old XMMS equalization code.])
-fi
-
 dnl Check for GTK/GLib/GThread/Pango
 
 PKG_CHECK_MODULES(GTK, [glib-2.0 >= 2.6.0 gtk+-2.0 >= 2.6.0 gthread-2.0 pango],
@@ -297,590 +275,6 @@
 
 AC_SUBST(VFS_BACKEND)
 
-dnl Check for esound
-
-AC_ARG_ENABLE( esd,
-    [  --disable-esd           disable esound output plugin [default=enabled]],
-    [enable_esd=$enableval],
-    [enable_esd="yes"]
-)
-
-if test "$enable_esd" = "yes"; then
-    PKG_CHECK_MODULES(ESD, [esound >= 0.2],
-        [have_esd=yes
-         OUTPUT_PLUGINS="$OUTPUT_PLUGINS esd"],
-        [have_esd=no]
-    )
-else
-    AC_MSG_RESULT([*** esound plugin disabled per user request ***])
-    have_esd=no
-fi
-
-dnl Check for PulseAudio
-
-AC_ARG_ENABLE( pulse,
-    [  --disable-pulse         disable PulseAudio output plugin [default=enabled]],
-    [enable_pulse=$enableval],
-    [enable_pulse="yes"]
-)
-
-if test "$enable_pulse" = "yes"; then
-    PKG_CHECK_MODULES(PULSE, [libpulse >= 0.9.3],
-         [have_pulse=yes
-          OUTPUT_PLUGINS="$OUTPUT_PLUGINS pulse_audio"],
-         [have_pulse=no]
-    )
-else
-    AC_MSG_RESULT([*** pulseaudio output plugin disabled per user request ***])
-    have_pulse=no
-fi
-
-dnl *** CoreAudio
-
-AC_ARG_ENABLE(coreaudio,
-    [  --disable-coreaudio     disable CoreAudio output plugin (default=enabled)],
-    [enable_coreaudio=$enableval],
-    [enable_coreaudio="yes"]
-)
-
-if test "$enable_coreaudio" = "yes"; then
-	AC_CHECK_HEADERS([CoreServices/CoreServices.h],
-		[have_coreaudio=yes
-		 OUTPUT_PLUGINS="$OUTPUT_PLUGINS CoreAudio"],
-		[have_coreaudio=no])
-else
-	AC_MSG_RESULT([*** CoreAudio output plugin disabled per user request ***])
-	have_coreaudio=no
-fi
-
-dnl *** AltiVec
-
-AC_CHECK_HEADERS(altivec.h,
-    [AC_DEFINE(HAVE_ALTIVEC, 1, [Define to 1 if your system has AltiVec.])
-     AC_DEFINE(HAVE_ALTIVEC_H, 1, [Define to 1 if your system has an altivec.h file.])
-     AC_DEFINE(ARCH_POWERPC, 1, [Define to 1 if your system is a PowerPC.])
-     DCT64=dct64_altivec.c],
-    [DCT64=dct64.c]
-)    
-AC_SUBST(DCT64)
-
-dnl *** MP3
-
-AC_ARG_ENABLE(mp3,
-    [  --disable-mp3           disable mp3 plugin. (default=enabled) ],
-    [enable_mp3=$enableval],
-    [enable_mp3=yes]
-)
-
-if test "$enable_mp3" = "yes"; then
-        INPUT_PLUGINS="$INPUT_PLUGINS mpg123"
-        PKG_CHECK_MODULES(LIBNMS,[libnms >= 0.6.0],
-            [LIBNMS_SRC=rtsp.c
-             AC_DEFINE(HAVE_NEMESI,,[Define if rtp/rtsp support is available])
-            ],[LIBNMS_SRC=""])
-        AC_SUBST(LIBNMS_CFLAGS)
-        AC_SUBST(LIBNMS_LIBS)
-        AC_SUBST(LIBNMS_SRC)
-fi
-
-dnl *** ThinkLight support
-
-AC_CHECK_FILE([/proc/acpi/ibm/light], [VISUALIZATION_PLUGINS="$VISUALIZATION_PLUGINS rocklight"])
-
-dnl *** LIRC client libraries
-
-AC_ARG_ENABLE(lirc,
-    [  --disable-lirc          disable LIRC plugin (default=enabled)],
-    [enable_lirc=$enableval],
-    [enable_lirc="yes"]
-)
-
-if test "$enable_lirc" = "yes"; then
-    AC_CHECK_LIB([lirc_client],[lirc_init],[have_lirc=yes],[have_lirc=no])
-else
-    AC_MSG_RESULT([*** LIRC plugin disabled per user request ***])
-    have_lirc="no"
-fi
-
-if test "$have_lirc" = "yes"; then
-	GENERAL_PLUGINS="$GENERAL_PLUGINS lirc"
-fi
-
-dnl *** libnotify requirement
-
-AC_ARG_ENABLE(notify,
-    [  --disable-notify        disable libnotify plugin (default=enabled)],
-    [enable_libnotify=$enableval],
-    [enable_libnotify="yes"]
-)
-
-if test "$enable_libnotify" = "yes"; then
-    PKG_CHECK_MODULES(LIBNOTIFY, [libnotify >= 0.4.2],
-        [have_libnotify=yes
-         GENERAL_PLUGINS="$GENERAL_PLUGINS notify"],
-        [have_libnotify=no]
-    )
-else
-    AC_MSG_RESULT([*** libnotify plugin disabled per user request ***])
-    have_libnotify="no"
-fi
-
-dnl *** AdPlug requirement (libbinio)
-
-AC_ARG_ENABLE(adplug,
-    [  --disable-adplug        disable AdPlug plugin (default=enabled)],
-    [enable_adplug=$enableval],
-    [enable_adplug="yes"]
-)
-
-if test "$enable_adplug" = "yes"; then
-    have_adplug="yes"
-    PKG_CHECK_MODULES(BINIO,[libbinio >= 1.4],,[have_adplug=no])
-else
-    AC_MSG_RESULT([*** AdPlug plugin disabled per user request ***])
-    have_adplug="no"
-fi
-
-if test "$have_adplug" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS adplug"
-fi
-
-dnl *** Ogg Vorbis
-
-AC_ARG_ENABLE(vorbis,
-    [  --disable-vorbis        disable Ogg Vorbis input plugin (default=enabled)],
-    [enable_vorbis=$enableval],
-    [enable_vorbis="yes"]
-)
-
-if test "$enable_vorbis" = "yes"; then
-    PKG_CHECK_MODULES(OGG_VORBIS, [ogg >= 1.0 vorbis >= 1.0 vorbisfile >= 1.0],
-        [have_oggvorbis=yes],
-        [AC_MSG_WARN([*** Cannot find libogg/libvorbis, Ogg Vorbis support will not be built ***])
-         have_oggvorbis=no]
-    )
-else
-    AC_MSG_RESULT([*** Ogg Vorbis plugin disabled per user request ***])
-    have_oggvorbis=no
-fi
-
-if test "$have_oggvorbis" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS vorbis"
-fi
-
-dnl *** AAC
-
-AC_ARG_ENABLE(aac,
-    [  --disable-aac           disable aac plugin (default=enabled) ],
-    [enable_aac=$enableval],
-    [enable_aac=yes]
-)
-
-if test "$enable_aac" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS aac"
-fi
-
-dnl *** sndfile
-
-AC_ARG_ENABLE(sndfile,
-    [  --disable-sndfile       disable sndfile extensions. [default=enabled] ],
-    [enable_sndfile=$enableval],
-    [enable_sndfile=yes]
-)
-
-if test "$enable_sndfile" = "yes"; then
-    PKG_CHECK_MODULES(SNDFILE, [sndfile >= 0.19],
-        [enable_sndfile=yes],
-        [enable_sndfile=no]
-    )
-else
-    AC_MSG_RESULT([*** libsndfile extensions disabled per user request ***])
-    enable_sndfile=no
-fi
-
-if test "$enable_sndfile" = "yes"; then
-	WAV_SNDFILE="-sndfile"
-fi
-
-AC_SUBST(WAV_SNDFILE)
-
-dnl *** modplug
-
-AC_ARG_ENABLE(modplug,
-    [  --disable-modplug       disable ModPlug plugin (default=enabled)],
-    [enable_modplug=$enableval],
-    [enable_modplug="yes"]
-)
-
-if test "$enable_modplug" = "yes"; then
-    AC_CHECK_LIB([modplug],[XMLinearTable],[have_modplug=yes],[have_modplug=no],[-lstdc++])
-else
-    AC_MSG_RESULT([*** ModPlug plugin disabled per user request ***])
-    have_modplug="no"
-fi
-
-if test "$have_modplug" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS modplug"
-fi
-
-dnl *** flac
-AC_ARG_ENABLE( flac,
-[  --disable-flac          disable flac input plugin (default=enabled)],,
-                enable_flac="yes")
-
-if test "x$enable_flac" = xyes; then
-        AM_PATH_LIBFLAC(have_flac=yes, have_flac=no)
-else
-        AC_MSG_RESULT([*** flac plugin disabled per user request ***])
-        have_flac=no
-fi
-
-if test "$have_flac" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS flac"
-fi
-
-dnl *** WMA
-
-AC_ARG_ENABLE(wma,
-    [  --disable-wma           disable wma plugin. (default=enabled)],
-    [enable_wma=$enableval],
-    [enable_wma=yes]
-)
-
-if test "$enable_wma" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS wma"
-fi
-
-dnl *** jack output plugin
-AC_ARG_ENABLE( jack,
-[  --disable-jack          disable jack output plugin (default=enabled)],,
-                enable_jack="yes")
-
-if test "x$enable_jack" = xyes; then
-        AM_PATH_JACK(have_jack=yes, have_jack=no)
-else
-        AC_MSG_RESULT([*** jack plugin disabled per user request ***])
-        have_jack=no
-fi
-
-if test "$have_jack" = yes; then
-	OUTPUT_PLUGINS="$OUTPUT_PLUGINS jack"
-fi
-
-dnl *** arts output plugin
-AC_ARG_ENABLE( arts,
-[  --disable-arts          disable arts output plugin (default=enabled)],,
-                enable_arts="yes")
-
-if test "x$enable_arts" = xyes; then
-        AM_PATH_ARTSC(0.9.5, have_arts=yes, have_arts=no)
-else
-        AC_MSG_RESULT([*** arts plugin disabled per user request ***])
-        have_arts=no
-fi
-
-if test "$have_arts" = yes; then
-	OUTPUT_PLUGINS="$OUTPUT_PLUGINS arts"
-fi
-
-dnl *** sid
-AC_ARG_ENABLE( sid,
-[  --disable-sid           disable sid input plugin (default=enabled)],,
-                enable_sid="yes")
-
-if test "x$enable_sid" = xyes; then
-        AM_PATH_SIDPLAY(have_sidplay=yes, have_sidplay=no)
-else
-        AC_MSG_RESULT([*** sid plugin disabled per user request ***])
-        have_sidplay=no
-fi
-
-if test "$have_sidplay" = yes; then
-	INPUT_PLUGINS="$INPUT_PLUGINS sid"
-fi
-
-dnl *** Musepack
-
-AC_ARG_ENABLE(musepack,
-    [  --disable-musepack      disable musepack input plugin (default=enabled)],
-    [enable_musepack=$enableval],
-    [enable_musepack="yes"]
-)
-
-if test "$enable_musepack" = "yes"; then
-    AC_CHECK_HEADERS(mpcdec/config_types.h,,
-        enable_musepack=no
-    )
-else
-    AC_MSG_RESULT([*** Musepack plugin disabled per user request ***])
-    enable_musepack=no
-fi
-
-if test "$enable_musepack" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS musepack"
-fi
-
-dnl *** OSS output
-
-AC_ARG_ENABLE(oss,
-    [  --disable-oss           disable the OSS output plugin (default=enabled)],
-    [enable_oss=$enableval],
-    [enable_oss=yes]
-)
-
-have_oss=no
-if test "$enable_oss" = "yes"; then
-    AC_MSG_CHECKING(for OSS include dir)
-    OSS_CFLAGS=""
-    if test -f "/etc/oss.conf" ; then
-        for i in `cat /etc/oss.conf`; do
-            t=`echo $i | sed -e 's/OSSLIBDIR=//'`
-            if test "$i" != "$t" ; then
-                if test -f "$t/include/sys/soundcard.h" -o -f "$i/include/soundcard.h" ; then
-                    OSS_CFLAGS="-I$t/include"
-                fi
-            fi
-        done
-    fi
-    if test -n "$OSS_CFLAGS" ; then
-        AC_MSG_RESULT([$OSS_CFLAGS])
-    else
-        AC_MSG_RESULT([not found])
-    fi
-    CFLAGS_save=$CFLAGS
-    CFLAGS="$CFLAGS $OSS_CFLAGS"
-    AC_CHECK_HEADERS(soundcard.h)
-    AC_CHECK_HEADERS(sys/soundcard.h)
-    AC_CHECK_HEADERS(machine/soundcard.h)
-    CFLAGS=$CFLAGS_save
-
-    if test "${ac_cv_header_soundcard_h}" = "yes" || test "${ac_cv_header_sys_soundcard_h}" = "yes" || test "${ac_cv_header_machine_soundcard_h}" = "yes"; then
-        have_oss=yes
-    fi
-
-	AC_MSG_CHECKING(whether we need -lossaudio)
-        AC_TRY_LINK([
-		#include <sys/ioctl.h>
-		#ifdef HAVE_SYS_SOUNDCARD_H
-		#include <sys/soundcard.h>
-		#else
-		#include <soundcard.h>
-		#endif
-        ], [
-		int fd, value;
-		ioctl(fd, SOUND_MIXER_READ_VOLUME, &value);
-	], AC_MSG_RESULT(no), [
-		OSS_LIBS="-lossaudio"
-		AC_MSG_RESULT(yes)
-        ])
-fi
-
-if test "$have_oss" = "yes"; then
-    AC_DEFINE(HAVE_OSS, 1, [Define if the OSS output plugin should be built])
-else
-    have_oss=no
-fi
-
-if test "$have_oss" = "yes"; then
-	OUTPUT_PLUGINS="$OUTPUT_PLUGINS OSS"
-fi
-
-AC_SUBST(OSS_LIBS)
-
-dnl *** ALSA output plugin
-
-AC_ARG_ENABLE(alsa,
-    [  --disable-alsa          disable ALSA input plugin (default=enabled)],
-    [enable_alsa=$enableval],
-    [enable_alsa=yes]
-)
-
-if test "$enable_alsa" = "yes"; then
-    PKG_CHECK_MODULES(ALSA, [alsa >= 1.0],
-[
-have_alsa=yes
-alsalib_available=yes
-],
-[
-have_alsa=no
-alsalib_available=no
-]
-    )
-else
-    AC_MSG_RESULT([*** ALSA output plugin disabled per user request ***])
-    have_alsa=no
-    alsalib_available=check
-fi
-
-if test "$have_alsa" = "yes"; then
-	OUTPUT_PLUGINS="$OUTPUT_PLUGINS alsa"
-fi
-
-
-dnl *** amidi-plug (note: to avoid checking twice ALSA, this should appear somewhere after the alsa ouput plugin check)
-
-AC_ARG_ENABLE(amidiplug,
-    [  --disable-amidiplug     disable amidi-plug input plugin (default=check) ],
-    [enable_amidiplug=$enableval],
-    [enable_amidiplug=check]
-)
-
-AC_ARG_ENABLE(amidiplug-alsa,
-    [  --disable-amidiplug-alsa    disable amidi-plug ALSA backend (default=enabled) ],
-    [enable_amidiplug_alsa=$enableval],
-    [enable_amidiplug_alsa=auto]
-)
-
-AC_ARG_ENABLE(amidiplug-flsyn,
-    [  --disable-amidiplug-flsyn   disable amidi-plug FluidSynth backend (default=enabled) ],
-    [enable_amidiplug_fluidsynth=$enableval],
-    [enable_amidiplug_fluidsynth=auto]
-)
-
-AC_ARG_ENABLE(amidiplug-dummy,
-    [  --disable-amidiplug-dummy   disable amidi-plug dummy backend (default=enabled) ],
-    [enable_amidiplug_dummy=$enableval],
-    [enable_amidiplug_dummy=auto]
-)
-
-
-if test "x$enable_amidiplug" = "xno"; then
-  AC_MSG_RESULT([*** amidi-plug disabled per user request ***])
-  enable_amidiplug=no
-else
-  if test "x$enable_amidiplug_alsa" != "xauto"; then
-    enable_amidiplug=yes
-  elif test "x$enable_amidiplug_fluidsynth" != "xauto"; then
-    enable_amidiplug=yes
-  elif test "x$enable_amidiplug_dummy" != "xauto"; then
-    enable_amidiplug=yes
-  fi
-fi
-
-if test "x$enable_amidiplug" = "xcheck"; then
-  if test "x$alsalib_available" = "xcheck"; then
-    PKG_CHECK_MODULES(ALSA, [alsa >= 1.0],
-      [alsalib_available=yes],[alsalib_available=no])
-  fi
-  if test "x$alsalib_available" = "xyes"; then
-    AM_PATH_AMIDIPLUG_HWSYNTH(ap_have_hwsynth=yes, ap_have_hwsynth=no)
-    if test "x$ap_have_hwsynth" = "xyes"; then
-      enable_amidiplug=yes
-      ap_disable_timidity=yes
-    else
-      PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth >= 1.0.6],
-        [fluidsynth_available=yes],[fluidsynth_available=no])
-      if test "x$fluidsynth_available" = "xyes"; then
-        enable_amidiplug=yes
-        ap_disable_timidity=yes
-      else
-        enable_amidiplug=no
-        AC_MSG_WARN([*** Neither an ALSA-supported hardware synth or FluidSynth software synth (>= 1.0.6) have been found (even if ALSA was detected), so amidi-plug won't be compiled unless you explicitly request it with --enable-amidiplug ***])
-      fi
-    fi
-  else
-    PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth >= 1.0.6],
-      [fluidsynth_available=yes],[fluidsynth_available=no])
-    if test "x$fluidsynth_available" = "xyes"; then
-      enable_amidiplug=yes
-      ap_disable_timidity=yes
-    else
-      enable_amidiplug=no
-      AC_MSG_WARN([*** Neither ALSA or FluidSynth software synth (>= 1.0.6) have been found, so amidi-plug won't be compiled unless you explicitly request it with --enable-amidiplug ***])
-    fi
-  fi
-fi
-
-if test "x$enable_amidiplug" = "xyes"; then
-  INPUT_PLUGINS="$INPUT_PLUGINS amidi-plug"
-  PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.6.0],,)
-  PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.6.0],,)
-  AMIDIPLUGBACKENDDIR=${libdir}/amidi-plug/backends
-  AC_SUBST(AMIDIPLUGBACKENDDIR)
-  if test "x$enable_amidiplug_alsa" = "xauto" -o "x$enable_amidiplug_alsa" = "xyes"; then
-    if test "x$alsalib_available" = "xcheck"; then
-      PKG_CHECK_MODULES(ALSA, [alsa >= 1.0],
-        [alsalib_available=yes],[alsalib_available=no])
-    fi
-    if test "x$alsalib_available" = "xyes"; then
-      AMIDIPLUG_BACKENDS="$AMIDIPLUG_BACKENDS backend-alsa"
-      enable_amidiplug_alsa=yes
-    else
-      if test "x$enable_amidiplug_alsa" = "xyes"; then
-        AC_MSG_ERROR([Cannot find ALSA development files (ver >= 1.0), but compilation of AMIDI-Plug ALSA backend has been explicitly requested; please install ALSA dev files and run configure again])
-        enable_amidiplug_alsa=no
-      else
-        enable_amidiplug_alsa=no
-      fi
-    fi
-  fi
-  if test "x$enable_amidiplug_fluidsynth" = "xauto" -o "x$enable_amidiplug_fluidsynth" = "xyes"; then
-    if test "x$fluidsynth_available" != "xyes" -a "x$fluidsynth_available" != "xno"; then
-      PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth >= 1.0.6],
-        [fluidsynth_available=yes],[fluidsynth_available=no])
-    fi
-    if test "x$fluidsynth_available" = "xyes"; then
-      AMIDIPLUG_BACKENDS="$AMIDIPLUG_BACKENDS backend-fluidsynth"
-      enable_amidiplug_fluidsynth=yes
-    else
-      if test "x$enable_amidiplug_fluidsynth" = "xyes"; then
-        AC_MSG_ERROR([Cannot find FluidSynth development files (ver >= 1.0.6), but compilation of AMIDI-Plug FluidSynth backend has been explicitly requested; please install FluidSynth dev files and run configure again])
-        enable_amidiplug_fluidsynth=no
-      else
-        enable_amidiplug_fluidsynth=no
-      fi
-    fi
-  fi
-  if test "x$enable_amidiplug_dummy" = "xauto" -o "x$enable_amidiplug_dummy" = "xyes"; then
-    AMIDIPLUG_BACKENDS="$AMIDIPLUG_BACKENDS backend-dummy"
-    enable_amidiplug_dummy=yes
-  fi
-  AC_SUBST(AMIDIPLUG_BACKENDS)
-fi
-
-if test "x$enable_amidiplug" = "xyes"; then
-  INPUT_PLUGINS="$INPUT_PLUGINS amidi-plug"
-fi
-
-
-dnl *** TiMidity input plugin (note: should appear somewhere after the amidi-plug check)
-
-AC_ARG_ENABLE(timidity,
-[  --disable-timidity      disable timidity plugin. (default=enabled)],
-[enable_timidity=$enableval],
-[
-  if test "x$ap_disable_timidity" = "xyes"; then
-    enable_timidity=no
-  else
-    enable_timidity=yes
-  fi
-]
-)
-
-if test "$enable_timidity" = "yes"; then
-	INPUT_PLUGINS="$INPUT_PLUGINS timidity"
-fi
-
-dnl FreeBSD newpcm driver detection
-
-AC_CACHE_CHECK(for FreeBSD newpcm driver, beep_cv_newpcm_driver,
-    if test -r "/dev/sndstat"; then
-        grep 'newpcm' /dev/sndstat 2>/dev/null 1>/dev/null
-        if test "x$?" = "x0"; then
-            beep_cv_newpcm_driver="yes"
-        else
-            beep_cv_newpcm_driver="no"
-        fi
-    else
-        beep_cv_newpcm_driver="no"
-    fi
-)
-
-if test "$beep_cv_newpcm_driver" = "yes"; then
-    AC_DEFINE(HAVE_NEWPCM, 1, [Define if you have the FreeBSD newpcm driver])
-fi
-
-
 AC_CHECK_HEADERS(linux/cdrom.h)
 AC_CHECK_HEADERS(sys/cdio.h)
 AC_CHECK_HEADERS(sys/cdrio.h)
@@ -895,49 +289,9 @@
 
 AC_CHECK_FUNCS([mkdtemp getmntinfo statvfs strtoul lrintf])
 
-
-if test "${ac_cv_header_linux_cdrom_h}" = "yes" || test "${ac_cv_header_sys_cdio_h}" = "yes"
-then
-    INPUT_PLUGINS="cdaudio $INPUT_PLUGINS"
-    case "$host" in
-        *-*-sunos* | *-*-solaris* | *-*-linux*)
-            AC_DEFINE(BEEP_CDROM_SOLARIS,, [Define if cdrom access is in Solaris style])
-        ;;
-        *-*-freebsd*)
-            AC_DEFINE(BEEP_CDROM_BSD,, [Define if cdrom access is in BSD style])
-        ;;
-        *-*-netbsd* | *-*-openbsd*)
-            AC_DEFINE(BEEP_CDROM_BSD,, [Define if cdrom access is in BSD style])
-            AC_DEFINE(BEEP_CDROM_BSD_NETBSD,, [Define if cdrom access uses NetBSD variant])
-        ;;
-        *-*darwin*)
-            AC_DEFINE(BEEP_CDROM_BSD,, [Define if cdrom access is in BSD style])
-            AC_DEFINE(BEEP_CDROM_BSD_DARWIN,, [Define if cdrom access uses Darwin variant])
-        ;;
-    esac
-fi
-
-
 AM_CONDITIONAL(HAVE_CDROM, test "${ac_cv_header_linux_cdrom_h}" = "yes" || test "${ac_cv_header_sys_cdio_h}" = "yes")
 AM_CONDITIONAL(HAVE_LINUX_JOYSTICK,test "${ac_cv_header_linux_joystick_h}" = "yes")
 
-if test -n "$GCC"
-then
-    CFLAGS="$CFLAGS -Wall -Wno-unused-parameter -Wpointer-arith -finline-functions -ffast-math"
-    case "$CFLAGS" in
-        -g*) ;;
-        *\ -g*) ;;
-        *) CFLAGS="$CFLAGS -fomit-frame-pointer" ;;
-    esac
-    case "$host" in
-        *-*-freebsd*)
-        ;;
-        *)
-        CFLAGS="$CFLAGS -funroll-all-loops"
-        ;;
-    esac
-fi
-
 AC_MSG_CHECKING(if __ELF__ is defined)
 AC_EGREP_CPP(yes,
     [#ifdef __ELF__
@@ -949,7 +303,6 @@
 )
 AC_MSG_RESULT([${is_elf}])
 
-
 have_solaris=no
 have_sun=no
 ARCH_DEFINES=""
@@ -1134,60 +487,6 @@
 	libaudacious/Makefile
 	libguess/Makefile
 	librcd/Makefile
-	Plugins/Makefile
-	Plugins/Output/Makefile
-	Plugins/Output/OSS/Makefile
-	Plugins/Output/esd/Makefile
-	Plugins/Output/alsa/Makefile
-	Plugins/Output/jack/Makefile
-	Plugins/Output/arts/Makefile
-	Plugins/Output/arts/arts_helper/Makefile
-	Plugins/Output/disk_writer/Makefile
-	Plugins/Output/pulse_audio/Makefile
-	Plugins/Output/sun/Makefile
-	Plugins/Input/Makefile
-	Plugins/Input/mpg123/Makefile
-	Plugins/Input/aac/Makefile
-	Plugins/Input/aac/mp4ff/Makefile
-	Plugins/Input/aac/libfaad2/Makefile
-	Plugins/Input/aac/src/Makefile
-	Plugins/Input/modplug/Makefile
-	Plugins/Input/modplug/archive/Makefile
-	Plugins/Input/modplug/gui/Makefile
-	Plugins/Input/musepack/Makefile
-	Plugins/Input/tonegen/Makefile
-        Plugins/Input/vorbis/Makefile
-        Plugins/Input/cdaudio/Makefile
-        Plugins/Input/wav/Makefile
-	Plugins/Input/flac/Makefile
-	Plugins/Input/flac/plugin_common/Makefile
-	Plugins/Input/sid/Makefile
-	Plugins/Input/wma/Makefile
-	Plugins/Input/wma/libffwma/Makefile
-	Plugins/Input/timidity/Makefile
-	Plugins/Input/timidity/libtimidity/Makefile
-	Plugins/Input/timidity/src/Makefile
-	Plugins/Input/sexypsf/Makefile
-	Plugins/Input/adplug/Makefile
-	Plugins/Input/adplug/core/Makefile
-	Plugins/Input/amidi-plug/Makefile
-	Plugins/Input/amidi-plug/pcfg/Makefile
-	Plugins/Input/amidi-plug/backend-alsa/Makefile
-	Plugins/Input/amidi-plug/backend-fluidsynth/Makefile
-	Plugins/Input/amidi-plug/backend-dummy/Makefile
-	Plugins/Visualization/Makefile
-	Plugins/Visualization/blur_scope/Makefile
-	Plugins/Visualization/rocklight/Makefile
-	Plugins/General/Makefile
-	Plugins/General/song_change/Makefile
-	Plugins/General/lirc/Makefile
-	Plugins/General/scrobbler/Makefile
-	Plugins/Effect/Makefile
-	Plugins/Effect/audiocompress/Makefile
-	Plugins/Effect/ladspa/Makefile
-	Plugins/Effect/stereo_plugin/Makefile
-	Plugins/Effect/voice_removal/Makefile
-	Plugins/Container/Makefile
 	po/Makefile.in
 	intl/Makefile
 	icons/Makefile
@@ -1212,73 +511,11 @@
 echo "  Use one plugin dir:                     $enable_one_plugin_dir"
 echo "  Allow user plugin dir:                  $enable_user_plugin_dir"
 echo
-echo "  XMMS Legacy"
-echo "  -----------"
-echo "  Equalization (works only with mpg123)   $use_xmms_eq"
-echo
 echo "  GNOME support"
 echo "  -------------"
 echo "  GConf support                           $enable_gconf"
 echo "  VFS support                             $enable_gnomevfs"
 echo
-echo "  Output Plugins"
-echo "  --------------"
-echo "  Open Sound System (oss):                $have_oss"
-echo "  Advanced Linux Sound Arch. (alsa):      $have_alsa"
-echo "  Enlightenment Sound Daemon (esd):       $have_esd"
-echo "  Jack Audio Connection Kit (jack):       $have_jack"
-echo "  Analog Realtime Synthesizer (arts):     $have_arts"
-echo "  BSD/SUN audio output (sun):             $have_sun"
-echo "  PulseAudio sound server (pulse_audio):  $have_pulse"
-echo "  Mac OS X sound support (CoreAudio):     $have_coreaudio"
-echo
-echo "  Input Plugins"
-echo "  -------------"
-echo "  MPEG 1/2/3 (mpg123):                    $enable_mp3"
-echo "  MPEG 4 Audio (AAC):                     $enable_aac"
-echo "  Windows Media Audio (wma):              $enable_wma"
-echo "  .mpc playback (musepack):               $enable_musepack"
-echo "  Module decoder (modplug):               $have_modplug"
-echo "  MIDI modular plugin (amidi-plug):       $enable_amidiplug"
-echo "    -> ALSA backend:                      $enable_amidiplug_alsa"
-echo "    -> FluidSynth backend:                $enable_amidiplug_fluidsynth"
-echo "    -> dummy backend:                     $enable_amidiplug_dummy"
-echo "  MIDI to WAVE converter (timidity):      $enable_timidity"
-echo "  CD Digital Audio (cdda):                yes"
-echo "  Microsoft WAV (wav):                    yes"
-echo "    + sndfile extensions:                 $enable_sndfile"
-echo "  Tone Generator:                         yes"
-echo "  Ogg Vorbis (vorbis):                    $have_oggvorbis"
-echo "  Free Lossless Audio Codec (flac):       $have_flac"
-echo "  Commodore 64 audio (sid):               $have_sidplay"
-echo "  Game music (spc, nsf & gbs):            yes"
-echo "  PlayStation audio (sexypsf):            yes"
-echo "  AdLib synthesizer (adplug):             $have_adplug"
-echo
-echo "  General"
-echo "  -------"
-echo "  Song Change:                            yes"
-echo "  LIRC:                                   $have_lirc"
-echo "  AudioScrobbler Client:                  $scrobbler"
-echo "  libnotify Plugin:                       $have_libnotify"
-echo
-echo "  Effect"
-echo "  ------"
-echo "  AudioCompressor (AGC):                  yes"
-echo "  LADSPA effects host (ladspa):           yes"
-echo "  Voice Removal:                          yes"
-echo
-echo "  Visualization"
-echo "  -------------"
-echo "  Blur Scope:                             yes"
-echo "  Paranormal Visualization Library:       $have_paranormal"
-echo
-echo "  Container"
-echo "  -------------"
-echo "  Winamp PLS playlist format (pls):       yes"
-echo "  M3U playlist format (m3u):              yes"
-echo "  XML Sharable Playlist Format (xspf):    $have_xspf"
-echo
 
 if test "$beep_cv_lib_xlibs_threadsafe" = "no"; then
     echo "Note: You need to have thread-safe xlibs to use Audacious."