diff configure.ac @ 810:e9509e909193 trunk

[svn] ported xmms-arts 0.7.1 to audacious and integrated it in the build process
author giacomo
date Thu, 09 Mar 2006 09:55:56 -0800
parents 0892e7d48925
children f9a1ddb72432
line wrap: on
line diff
--- a/configure.ac	Wed Mar 08 11:16:59 2006 -0800
+++ b/configure.ac	Thu Mar 09 09:55:56 2006 -0800
@@ -429,6 +429,22 @@
 	OUTPUT_PLUGINS="$OUTPUT_PLUGINS jack"
 fi
 
+dnl *** arts output plugin
+AC_ARG_ENABLE( arts,
+[  --disable-arts          disable arts output plugin (default=enabled)],,
+                enable_arts="yes")
+
+if test "x$enable_arts" = xyes; then
+        AM_PATH_ARTSC(0.9.5, have_arts=yes, have_arts=no)
+else
+        AC_MSG_RESULT([*** arts plugin disabled per user request ***])
+        have_arts=no
+fi
+
+if test "$have_arts" = yes; then
+	OUTPUT_PLUGINS="$OUTPUT_PLUGINS arts"
+fi
+
 dnl *** sid
 AC_ARG_ENABLE( sid,
 [  --disable-sid           disable sid input plugin (default=enabled)],,
@@ -846,6 +862,8 @@
         Plugins/Output/esd/Makefile
         Plugins/Output/alsa/Makefile
 	Plugins/Output/jack/Makefile
+	Plugins/Output/arts/Makefile
+	Plugins/Output/arts/arts_helper/Makefile
 	Plugins/Output/disk_writer/Makefile
 	Plugins/Output/sun/Makefile
         Plugins/Input/Makefile
@@ -923,6 +941,7 @@
 echo "  Advanced Linux Sound Arch. (alsa):      $have_alsa"
 echo "  Enlightenment Sound Daemon (esd):       $have_esd"
 echo "  Jack Audio Connection Kit (jack):       $have_jack"
+echo "  Analog Realtime Synthesizer (arts):     $have_arts"
 echo "  BSD/SUN audio output (sun):             $have_sun"
 echo
 echo "  Input Plugins"