diff configure.in @ 44890:01b93e5e53a7

Patch for building Emacs on Mac OS X. April 26, 2002. See ChangeLog, lisp/ChangeLog, and src/ChangeLog for list of changes.
author Andrew Choi <akochoi@shaw.ca>
date Fri, 26 Apr 2002 23:39:06 +0000
parents a99665332964
children 2f87e3be106c
line wrap: on
line diff
--- a/configure.in	Fri Apr 26 22:33:33 2002 +0000
+++ b/configure.in	Fri Apr 26 23:39:06 2002 +0000
@@ -128,6 +128,8 @@
                           don't use Motif or Xaw3d scroll bars])
 AC_ARG_WITH(xim,
 [  --without-xim           don't use X11 XIM])
+AC_ARG_WITH(carbon,
+[  --without-carbon        don't use Carbon GUI on Mac OS X])
 
 #### Make srcdir absolute, if it isn't already.  It's important to
 #### avoid running the path through pwd unnecessarily, since pwd can
@@ -1104,6 +1106,13 @@
     machine=f301 opsys=uxpv
   ;;
 
+  ## Darwin / Mac OS X
+  powerpc-apple-darwin* )
+    machine=powermac opsys=darwin
+    # Define CPP as follows to make autoconf work correctly.
+    CPP="cc -E -traditional-cpp"
+  ;;
+
   * )
     unported=yes
   ;;
@@ -1997,6 +2006,16 @@
   fi
 fi
 
+### Use Mac OS X Carbon API to implement GUI.
+HAVE_CARBON=no
+if test "${with_carbon}" != "no"; then
+  AC_CHECK_HEADER(Carbon/Carbon.h, HAVE_CARBON=yes)
+fi
+
+if test "${HAVE_CARBON}" = "yes"; then
+  AC_DEFINE(HAVE_CARBON)
+fi
+
 ### Use session management (-lSM -lICE) if available
 HAVE_X_SM=no
 if test "${HAVE_X11}" = "yes"; then