diff configure.in @ 48220:0230b8ae41f0

Use AC_CONFIG_LIBOBJ_DIR and require autoconf 2.54. (AH_BOTTOM) [!HAVE_SIZE_T]: Typedef size_t.
author Dave Love <fx@gnu.org>
date Fri, 08 Nov 2002 12:30:21 +0000
parents 8ebe39e6efe1
children 58aeaa1dbcfa
line wrap: on
line diff
--- a/configure.in	Fri Nov 08 09:04:59 2002 +0000
+++ b/configure.in	Fri Nov 08 12:30:21 2002 +0000
@@ -23,7 +23,7 @@
 dnl  Free Software Foundation, Inc., 59 Temple Place - Suite 330,
 dnl  Boston, MA 02111-1307, USA.
 
-AC_PREREQ(2.53)dnl
+AC_PREREQ(2.54)dnl
 AC_INIT(src/lisp.h)
 AC_CONFIG_HEADER(src/config.h:src/config.in)
 
@@ -1382,6 +1382,9 @@
   CPPFLAGS="$c_switch_system $c_switch_machine $CPPFLAGS"
 fi
 
+dnl For AC_FUNC_GETLOADAVG, at least:
+AC_CONFIG_LIBOBJ_DIR(src)
+
 dnl Do this early because it can frob feature test macros for Unix-98 &c.
 AC_SYS_LARGEFILE
 
@@ -1394,6 +1397,8 @@
 fi
 
 dnl checks for header files
+dnl NB. On Solaris 8 there's a warning from the check for term.h because
+dnl it needs something else (curses.h?) to define `bool'.
 AC_CHECK_HEADERS(sys/select.h sys/timeb.h sys/time.h unistd.h utime.h \
   linux/version.h sys/systeminfo.h termios.h limits.h string.h stdlib.h \
   termcap.h stdio_ext.h fcntl.h term.h strings.h coff.h pty.h sys/mman.h \
@@ -2607,6 +2612,9 @@
 #ifdef HAVE_STDLIB_H
 #include <stdlib.h>
 #endif
+#ifndef HAVE_SIZE_T
+typedef size_t unsigned
+#endif
 #endif
 
 /* Define HAVE_X_I18N if we have usable i18n support.  */