diff configure.in @ 99245:03f5d6ae5684

Check fontconfig always.
author Kenichi Handa <handa@m17n.org>
date Thu, 30 Oct 2008 07:11:14 +0000
parents 33f425648e13
children 71576fddc0a7
line wrap: on
line diff
--- a/configure.in	Thu Oct 30 04:37:40 2008 +0000
+++ b/configure.in	Thu Oct 30 07:11:14 2008 +0000
@@ -1825,6 +1825,8 @@
 fi
 
 ### Start of font-backend section.
+PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 2.2.0, HAVE_FC=yes, HAVE_FC=no)
+test "${HAVE_FC}" = "no" && with_freetype=no
 
 ## Use -lXft if available, unless `--with-freetype=no' nor `--with-xft=no'.
 HAVE_XFT=maybe
@@ -1868,16 +1870,11 @@
   dnl As we use Xft, we anyway use freetype.
   dnl In this case, there's no need of additional CFLAGS and LIBS.
   HAVE_FREETYPE=yes
+  FONTCONFIG_CFLAGS=
+  FONTCONFIG_LIBS=
 elif test "x${with_freetype}" != "xno" && test "x${with_x}" != "xno"; then
 
   PKG_CHECK_MODULES(FREETYPE, freetype2, HAVE_FREETYPE=yes, HAVE_FREETYPE=no)
-  if test "${HAVE_FREETYPE}" = "yes"; then
-    PKG_CHECK_MODULES(FONTCONFIG, fontconfig, HAVE_FC=yes, HAVE_FC=no)
-    if test "${HAVE_FC}" = "no"; then
-      dnl Without fontconfig, we can't use freetype at the moment.
-      HAVE_FREETYPE=no
-    fi
-  fi
 fi
 
 HAVE_LIBOTF=no