diff configure.in @ 108171:06a18c2b3272

Replace some cpp with autoconf. * configure.in (OTHER_OBJ): New output variable. * src/Makefile.in (mallocobj): Remove. (otherobj): Simplify using @OTHER_OBJ@.
author Glenn Morris <rgm@gnu.org>
date Thu, 29 Apr 2010 18:36:42 -0700
parents 41f5a4a424d8
children c9d0b6bfe74e
line wrap: on
line diff
--- a/configure.in	Thu Apr 29 18:27:33 2010 -0700
+++ b/configure.in	Thu Apr 29 18:36:42 2010 -0700
@@ -2928,9 +2928,18 @@
 	     buffer space.])
 fi
 
+
+OTHER_OBJ="\$(gmallocobj) \$(rallocobj)"
+if test "$opsys" = "cygwin"; then
+  CYGWIN_OBJ="sheap.o"
+  ## Cygwin differs because of its unexec().
+  OTHER_OBJ="$OTHER_OBJ lastfile.o"
+else
 CYGWIN_OBJ=
-test "$opsys" = "cygwin" && CYGWIN_OBJ="sheap.o"
+  OTHER_OBJ="lastfile.o $OTHER_OBJ"
+fi
 AC_SUBST(CYGWIN_OBJ)
+AC_SUBST(OTHER_OBJ)
 
 AH_TOP([/* GNU Emacs site configuration template file.
    Copyright (C) 1988, 1993, 1994, 1999, 2000, 2001, 2002, 2004, 2005,