diff configure.in @ 89985:0b158db81c28

Revision: miles@gnu.org--gnu-2004/emacs--unicode--0--patch-44 Merge from emacs--cvs-trunk--0 Patches applied: * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-562 Update from CVS: lisp/subr.el (after-change-major-mode-hook): Doc fix. * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-563 - miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-570 Update from CVS
author Miles Bader <miles@gnu.org>
date Sat, 25 Sep 2004 12:05:36 +0000
parents 4c90ffeb71c5 6e40bed9e91e
children e23928ac5a97
line wrap: on
line diff
--- a/configure.in	Tue Sep 21 20:44:26 2004 +0000
+++ b/configure.in	Sat Sep 25 12:05:36 2004 +0000
@@ -1286,6 +1286,17 @@
 dnl checks for Unix variants
 AC_AIX
 
+dnl check if exec-shield is present.
+AC_CHECK_FILE(/proc/sys/kernel/exec-shield, emacs_cv_execshield=1,
+					    emacs_cv_execshield=0)
+if test "$emacs_cv_execshield" = 1; then
+   AC_PATH_PROG(SETARCH, setarch, no)
+   AC_SUBST(SETARCH)
+   if test "$setarch" != no; then
+     AC_DEFINE(HAVE_EXECSHIELD, 1, [Define to 1 if this OS has exec shield.])
+   fi
+fi
+
 #### Extract some information from the operating system and machine files.
 
 AC_CHECKING([the machine- and system-dependent files to find out
@@ -2342,7 +2353,7 @@
 __fpending mblen mbrlen mbsinit strsignal setitimer ualarm index rindex \
 sendto recvfrom getsockopt setsockopt getsockname getpeername \
 gai_strerror mkstemp getline getdelim mremap memmove fsync bzero \
-memset memcmp memmove difftime memcpy mempcpy mblen mbrlen posix_memalign)
+memset memcmp difftime memcpy mempcpy mblen mbrlen posix_memalign)
 
 AC_CHECK_HEADERS(sys/un.h)