diff configure.in @ 36901:0c5978b5eb3a

(HAVE_XPM): Don't print the result of the check for XpmReturnAllocPixels if we don't have an xpm.h.
author Gerd Moellmann <gerd@gnu.org>
date Tue, 20 Mar 2001 15:47:08 +0000
parents f98c16e68579
children 57f54fb91332
line wrap: on
line diff
--- a/configure.in	Tue Mar 20 15:37:50 2001 +0000
+++ b/configure.in	Tue Mar 20 15:47:08 2001 +0000
@@ -1811,18 +1811,19 @@
     AC_CHECK_HEADER(X11/xpm.h,
       AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
     if test "${HAVE_XPM}" = "yes"; then
-       AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
-       AC_EGREP_CPP(no_return_alloc_pixels,
-       [#include "X11/xpm.h"
+      AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
+      AC_EGREP_CPP(no_return_alloc_pixels,
+      [#include "X11/xpm.h"
 #ifndef XpmReturnAllocPixels
 no_return_alloc_pixels
 #endif
-	], HAVE_XPM=no, HAVE_XPM=yes)
-    fi
-    if test "${HAVE_XPM}" = "yes"; then
-       AC_MSG_RESULT(yes)
-    else
-       AC_MSG_RESULT(no)
+      ], HAVE_XPM=no, HAVE_XPM=yes)
+
+      if test "${HAVE_XPM}" = "yes"; then
+	AC_MSG_RESULT(yes)
+      else
+	AC_MSG_RESULT(no)
+      fi
     fi
   fi