diff configure.in @ 97354:0defde3a9c5f

* s/darwin.h (OTHER_FILES): Do not define here, defined in config.in. * Makefile.in (ALL_OBJC_CFLAGS): New variable. (.m.o): Use it. * config.in: Regenerate. * Makefile.in (INSTALLABLES): Add LIB_SRC_EXTRA_INSTALLABLES. Do not special case for NS_IMPL_COCOA. * configure.in (LIB_SRC_EXTRA_INSTALLABLES): New variable. AC_SUBST it. (GNU_OBJC_CFLAGS): Define as a shell variable instead of #define. AC_SUBST it. (OTHER_FILES): Always define for HAVE_NS. (C_SWITCH_X_SYSTEM): Don't define as empty for NS_IMPL_COCOA. * configure: Regenerate.
author Dan Nicolaescu <dann@ics.uci.edu>
date Thu, 07 Aug 2008 14:21:43 +0000
parents 945ae0a5779f
children 7c5d85abccae
line wrap: on
line diff
--- a/configure.in	Thu Aug 07 09:29:58 2008 +0000
+++ b/configure.in	Thu Aug 07 14:21:43 2008 +0000
@@ -2049,12 +2049,15 @@
   AC_DEFINE(HAVE_NS, 1, [Define to 1 if you are using the NeXTstep API, either GNUstep or Cocoa on Mac OS X.])
   if test "${NS_IMPL_COCOA}" = "yes"; then
     AC_DEFINE(NS_IMPL_COCOA, 1, [Define to 1 if you are using NS windowing under MacOS X.])
+    GNU_OBJC_CFLAGS=
+    LIB_SRC_EXTRA_INSTALLABLES=mac-fix-env
   fi
   if test "${EN_COCOA_EXPERIMENTAL_CTRL_G}" = "yes"; then
     AC_DEFINE(COCOA_EXPERIMENTAL_CTRL_G, 1, [Define to 1 if you are trying experimental enhanced Ctrl-g support using NS windowing under MacOS X.])
   fi
   if test "${NS_IMPL_GNUSTEP}" = "yes"; then
     AC_DEFINE(NS_IMPL_GNUSTEP, 1, [Define to 1 if you are using NS windowing under GNUstep.])
+    GNU_OBJC_CFLAGS="-fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE"
   fi
   if test "${NS_HAVE_NSINTEGER}" = "yes"; then
     AC_DEFINE(NS_HAVE_NSINTEGER, 1, [Define to 1 if `NSInteger' is defined.])
@@ -2464,6 +2467,8 @@
 AC_SUBST(ns_appresdir)
 AC_SUBST(ns_appsrc)
 AC_SUBST(GNUSTEP_MAKEFILES)
+AC_SUBST(GNU_OBJC_CFLAGS)
+AC_SUBST(LIB_SRC_EXTRA_INSTALLABLES)
 
 AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION,  "${canonical}",
 		   [Define to the canonical Emacs configuration name.])
@@ -2607,18 +2612,14 @@
    side does this in s/darwin.h and we cannot
    parallel this exactly since GNUstep is multi-OS. */
 #ifdef HAVE_NS
+#define OTHER_FILES ns-app
 # ifdef NS_IMPL_GNUSTEP
 /* See also .m.o rule in Makefile.in */
 #  define C_SWITCH_X_SYSTEM -D_REENTRANT -fPIC -fno-strict-aliasing
-#  define GNU_OBJC_CFLAGS -fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE
-#  define OTHER_FILES ns-app
-# else /* NS_IMPL_COCOA */
-#  define C_SWITCH_X_SYSTEM
-#  define GNU_OBJC_CFLAGS
-# endif /* NS_IMPL_COCOA */
+# endif /* NS_IMPL_GNUSTEP */
 #endif /* HAVE_NS */
 
-/* Define `subprocesses' should be defined if you want to
+/* `subprocesses' should be defined if you want to
    have code for asynchronous subprocesses
    (as used in M-x compile and M-x shell).
    Only MSDOS does not support this.  */