diff configure.in @ 43824:0f0939983d10

Added test for X Session Management (HAVE_X_SM).
author Jan Djärv <jan.h.d@swipnet.se>
date Sun, 10 Mar 2002 16:37:56 +0000
parents 050eee3f784f
children 0d25d20876a2
line wrap: on
line diff
--- a/configure.in	Sun Mar 10 16:31:43 2002 +0000
+++ b/configure.in	Sun Mar 10 16:37:56 2002 +0000
@@ -1935,6 +1935,21 @@
   fi
 fi
 
+### Use session management (-lSM -lICE) if available
+HAVE_X_SM=no
+if test "${HAVE_X11}" = "yes"; then
+  AC_CHECK_HEADER(X11/SM/SMlib.h,
+    AC_CHECK_LIB(SM, SmcOpenConnection, HAVE_X_SM=yes, -lICE))
+
+  if test "${HAVE_X_SM}" = "yes"; then
+    AC_DEFINE(HAVE_X_SM)
+    case "$LIBS" in
+      *-lSM*) ;;
+      *)      LIBS="-lSM -lICE $LIBS" ;;
+    esac
+  fi
+fi
+  
 # If netdb.h doesn't declare h_errno, we must declare it by hand.
 AC_CACHE_CHECK(whether netdb declares h_errno,
 	       emacs_cv_netdb_declares_h_errno,