diff configure.in @ 108217:100210917be8

Replace some X-related cpp with autoconf. * configure.in (LIBXT_OTHER, LIBX_OTHER): New output variables. * src/Makefile.in (LIBX_EXTRA, LIBX_BASE): New variables. (LIBXT_OTHER, LIBX_OTHER): New, set by configure. (LIBXT): Set with configure, not cpp. (LIBX): Remove. (LIBES): Replace $LIBX with $LIBX_BASE and $LIBX_OTHER.
author Glenn Morris <rgm@gnu.org>
date Sun, 02 May 2010 19:10:43 -0700
parents f015ae3fb447
children 135e34f90ef1
line wrap: on
line diff
--- a/configure.in	Sun May 02 18:53:58 2010 -0700
+++ b/configure.in	Sun May 02 19:10:43 2010 -0700
@@ -2903,6 +2903,13 @@
 esac
 AC_SUBST(TOOLKIT_LIBW)
 
+if test "$USE_X_TOOLKIT" = "none"; then
+  LIBXT_OTHER="\$(LIBXSM)"
+else
+  LIBXT_OTHER="\$(LIBXMU) -lXt \$(LIBXTR6) -lXext"
+fi
+AC_SUBST(LIBXT_OTHER)
+
 ## The X Menu stuff is present in the X10 distribution, but missing
 ## from X11.  If we have X10, just use the installed library;
 ## otherwise, use our own copy.
@@ -2917,9 +2924,11 @@
     OLDXMENU="\${lwlibdir}liblw.a"
   fi
   LIBXMENU="\$(OLDXMENU)"
+  LIBX_OTHER="\$(LIBXT) \$(LIBX_EXTRA)"
 else
   OLDXMENU=
   LIBXMENU="-lXMenu"
+  LIBX_OTHER=
 fi
 
 if test "$HAVE_GTK" = "yes"; then
@@ -2929,6 +2938,7 @@
 
 AC_SUBST(OLDXMENU)
 AC_SUBST(LIBXMENU)
+AC_SUBST(LIBX_OTHER)
 
 if test "${HAVE_MENUS}" = "yes" ; then
   AC_DEFINE(HAVE_MENUS, 1,