diff configure.in @ 110905:158de1f7d257

Pass CFLAGS to the linker. * configure.in (PROFILING_LDFLAGS): Do not define, remove all uses. * lib-src/Makefile.in (PROFILING_LDFLAGS): Remove, not needed. * msdos/sed1v2.inp (PROFILING_LDFLAGS): * msdos/sed3v2.inp (PROFILING_LDFLAGS): Remove, not defined anymore. * src/Makefile.in (temacs): Use $(ALL_CFLAGS) on the link line. (PROFILING_LDFLAGS): Remove, not needed anymore.
author Dan Nicolaescu <dann@ics.uci.edu>
date Sun, 10 Oct 2010 08:35:04 -0700
parents b71665f4f9ba
children 07776ed6876f
line wrap: on
line diff
--- a/configure.in	Sun Oct 10 07:47:43 2010 -0700
+++ b/configure.in	Sun Oct 10 08:35:04 2010 -0700
@@ -325,13 +325,10 @@
 [ac_enable_profiling="${enableval}"],[])
 if test x$ac_enable_profiling != x ; then
    PROFILING_CFLAGS="-DPROFILING=1 -pg"
-   PROFILING_LDFLAGS="-pg"
 else
    PROFILING_CFLAGS=
-   PROFILING_LDFLAGS=
 fi
 AC_SUBST(PROFILING_CFLAGS)
-AC_SUBST(PROFILING_LDFLAGS)
 
 AC_ARG_ENABLE(autodepend,
 [AS_HELP_STRING([--enable-autodepend],
@@ -1487,7 +1484,7 @@
 tmp_CFLAGS="$CFLAGS"
 CPPFLAGS="$CPPFLAGS -x objective-c"
 CFLAGS="$CFLAGS -x objective-c"
-TEMACS_LDFLAGS2="\${LDFLAGS} \${PROFILING_LDFLAGS}"
+TEMACS_LDFLAGS2="\${LDFLAGS}"
 dnl I don't think it's especially important, but src/Makefile.in
 dnl (now the only user of ns_appdir) used to go to the trouble of adding a
 dnl trailing "/" to it, so now we do it here.