diff configure.in @ 108148:1c3ecdb885b5

Move LIBXMU from cpp to configure. * configure.in (LIBXMU): New output variable. * src/Makefile.in (LIBXMU): Set with configure, not cpp. * src/s/aix4-2.h (LIBXMU): * src/s/hpux10-20.h (LIBXMU): Remove definition, now set in configure.
author Glenn Morris <rgm@gnu.org>
date Wed, 28 Apr 2010 00:01:43 -0700
parents 40b36ac1946f
children 1af337cb46c4
line wrap: on
line diff
--- a/configure.in	Tue Apr 27 23:54:25 2010 -0700
+++ b/configure.in	Wed Apr 28 00:01:43 2010 -0700
@@ -1890,6 +1890,17 @@
 fi
 AC_SUBST(LIBXTR6)
 
+dnl FIXME the logic here seems weird, but this is what cpp was doing.
+dnl Why not just test for libxmu in the normal way?
+LIBXMU=-lXmu
+case "$machine" in
+  ## These machines don't supply Xmu.
+  hpux* | aix4-2 )
+    test "X$ac_cv_lib_Xmu_XmuConvertStandardSelection" = "Xno" && LIBXMU=
+    ;;
+esac
+AC_SUBST(LIBXMU)
+
 # On Irix 6.5, at least, we need XShapeQueryExtension from -lXext for Xaw3D.
 if test "${HAVE_X11}" = "yes"; then
   if test "${USE_X_TOOLKIT}" != "none"; then