diff configure.in @ 15830:248bde0ddbc6

(LOCALTIME_CACHE): Don't put a string literal "TZ=..." in environ.
author Richard M. Stallman <rms@gnu.org>
date Tue, 06 Aug 1996 08:21:51 +0000
parents fd9789979c58
children b2baf393982f
line wrap: on
line diff
--- a/configure.in	Mon Aug 05 21:28:14 1996 +0000
+++ b/configure.in	Tue Aug 06 08:21:51 1996 +0000
@@ -1438,16 +1438,18 @@
     if (! (to[0][0] == 'T' && to[0][1] == 'Z' && to[0][2] == '='))
       to++;
 }
+char TZ_GMT0[] = "TZ=GMT0";
+char TZ_PST8[] = "TZ=PST8";
 main()
 {
   time_t now = time ((time_t *) 0);
   int hour_GMT0, hour_unset;
-  if (putenv ("TZ=GMT0") != 0)
+  if (putenv (TZ_GMT0) != 0)
     exit (1);
   hour_GMT0 = localtime (&now)->tm_hour;
   unset_TZ ();
   hour_unset = localtime (&now)->tm_hour;
-  if (putenv ("TZ=PST8") != 0)
+  if (putenv (TZ_PST8) != 0)
     exit (1);
   if (localtime (&now)->tm_hour == hour_GMT0)
     exit (1);