diff configure.in @ 90116:29e773288013

Revision: miles@gnu.org--gnu-2005/emacs--unicode--0--patch-23 Merge from emacs--cvs-trunk--0 Patches applied: * miles@gnu.org--gnu-2005/emacs--cvs-trunk--0 (patch 150-165) - Update from CVS - Merge from gnus--rel--5.10 - Add info/dir to arch branch * miles@gnu.org--gnu-2005/gnus--rel--5.10 (patch 34-37) - Merge from emacs--cvs-trunk--0 - Update from CVS
author Miles Bader <miles@gnu.org>
date Wed, 09 Mar 2005 00:09:34 +0000
parents 6d92d69fae33 01e39f456dc6
children e330fedc9152
line wrap: on
line diff
--- a/configure.in	Tue Mar 08 08:37:20 2005 +0000
+++ b/configure.in	Wed Mar 09 00:09:34 2005 +0000
@@ -125,6 +125,11 @@
                           specify install directory for Emacs.app on Mac OS X]],
 [ carbon_appdir_x=${enableval}])
 
+AC_ARG_ENABLE(asserts,
+[  --enable-asserts        compile code with asserts enabled],
+      USE_XASSERTS=$enableval,
+      USE_XASSERTS=no)
+
 AC_ARG_ENABLE(maintainer-mode,
 [  --enable-maintainer-mode enable make rules and dependencies not useful
                           (and sometimes confusing) to the casual installer],
@@ -3096,19 +3101,15 @@
 echo "  Does Emacs use X toolkit scroll bars?                   ${USE_TOOLKIT_SCROLL_BARS}"
 echo
 
-if test "$emacs_cv_randomheap" = warn; then 
-  AC_MSG_WARN([
-**********************************************************************
-
-Heap start address is randomized and no workaround is known.
-Emacs will probably dump core when temacs is run in the build phase.
-Maybe exec-shield is turned on.  Read about exec-shield in `etc/PROBLEMS'
-for further information.
-
-**********************************************************************
-])
+if test $USE_XASSERTS = yes; then
+   echo "  Compiling with asserts turned on."
+   CFLAGS="$CFLAGS -DXASSERTS=1"
+   CPPFLAGS="$CPPFLAGS -DXASSERTS=1"
+   echo
 fi
 
+
+
 # Remove any trailing slashes in these variables.
 [test "${prefix}" != NONE &&
   prefix=`echo "${prefix}" | sed 's,\([^/]\)/*$,\1,'`