diff configure.in @ 57355:333180b73b52

configure.in (HAVE_RANDOM_HEAPSTART): Move output of warning message to end of configure run.
author Jan Djärv <jan.h.d@swipnet.se>
date Wed, 06 Oct 2004 12:28:31 +0000
parents c36defd6923f
children f95883a41a23
line wrap: on
line diff
--- a/configure.in	Wed Oct 06 07:29:55 2004 +0000
+++ b/configure.in	Wed Oct 06 12:28:31 2004 +0000
@@ -1613,16 +1613,8 @@
     AC_DEFINE(HAVE_RANDOM_HEAPSTART, 1,
     [Define to 1 if this OS randomizes the start address of the heap.])
   else
-    AC_MSG_WARN([
-**********************************************************************
-
-Heap start address is randomized and no workaround is known.
-Emacs will probably dump core when temacs is run in the build phase.
-Maybe exec-shield is turned on.  Read about exec-shield in `etc/PROBLEMS'
-for further information.
-
-**********************************************************************
-])
+    dnl We do the warning at the end of the configure run so it is seen.
+    emacs_cv_randomheap=warn
   fi
 fi
 
@@ -3094,6 +3086,19 @@
 echo "  Does Emacs use X toolkit scroll bars?                   ${USE_TOOLKIT_SCROLL_BARS}"
 echo
 
+if test "$emacs_cv_randomheap" = warn; then 
+  AC_MSG_WARN([
+**********************************************************************
+
+Heap start address is randomized and no workaround is known.
+Emacs will probably dump core when temacs is run in the build phase.
+Maybe exec-shield is turned on.  Read about exec-shield in `etc/PROBLEMS'
+for further information.
+
+**********************************************************************
+])
+fi
+
 # Remove any trailing slashes in these variables.
 [test "${prefix}" != NONE &&
   prefix=`echo "${prefix}" | sed 's,\([^/]\)/*$,\1,'`