diff configure.in @ 108584:3c49e77f15b7

Choose dependency of oldxmenu using configure. * configure.in (OLDXMENU_TARGET): New output variable. * src/Makefile.in (OLDXMENU_TARGET): New, set by configure. (really-lwlib, really-oldXMenu): Always define. ($OLDXMENU): Depend on $OLDXMENU_TARGET. * msdos/sed1v2.inp (OLDXMENU_TARGET): Edit to empty. * msdos/sed1x.inp (OLDXMENU_TARGET): Edit to really-oldxmenu.
author Glenn Morris <rgm@gnu.org>
date Fri, 14 May 2010 18:55:24 -0700
parents 58b814d12797
children 786c4a4a3817
line wrap: on
line diff
--- a/configure.in	Fri May 14 18:45:18 2010 -0700
+++ b/configure.in	Fri May 14 18:55:24 2010 -0700
@@ -3126,10 +3126,13 @@
 
 if test "$USE_X_TOOLKIT" = "none"; then
   LIBXT_OTHER="\$(LIBXSM)"
+  OLDXMENU_TARGET="really-oldXMenu"
 else
   LIBXT_OTHER="\$(LIBXMU) -lXt \$(LIBXTR6) -lXext"
+  OLDXMENU_TARGET="really-lwlib"
 fi
 AC_SUBST(LIBXT_OTHER)
+AC_SUBST(OLDXMENU_TARGET)
 
 ## The X Menu stuff is present in the X10 distribution, but missing
 ## from X11.  If we have X10, just use the installed library;