diff configure.in @ 31319:438bba3b3761

Add ``checking'' messages for XpmReturnAllocPixels.
author Gerd Moellmann <gerd@gnu.org>
date Fri, 01 Sep 2000 14:05:06 +0000
parents bceceed9ef87
children c0fe1ce00ebb
line wrap: on
line diff
--- a/configure.in	Fri Sep 01 13:50:50 2000 +0000
+++ b/configure.in	Fri Sep 01 14:05:06 2000 +0000
@@ -1778,6 +1778,7 @@
     AC_CHECK_HEADER(X11/xpm.h,
       AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
     if test "${HAVE_XPM}" = "yes"; then
+       AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
        AC_EGREP_CPP(no_return_alloc_pixels,
        [#include "X11/xpm.h"
 #ifndef XpmReturnAllocPixels
@@ -1786,6 +1787,11 @@
 	], HAVE_XPM=no, HAVE_XPM=yes)
     fi
     CFLAGS="${old_c_flags}"
+    if test "${HAVE_XPM}" = "yes"; then
+       AC_MSG_RESULT(yes)
+    else
+       AC_MSG_RESULT(no)
+    fi
   fi
 
   if test "${HAVE_XPM}" = "yes"; then