diff configure.in @ 108136:43dcbd8381dc

Move LIBXTR6 from cpp to autoconf. * configure.in (LIBXTR6): New output variable. Move unixware special case here from src/s/unixware.h. * src/Makefile.in (LIBXTR6): Set with configure, not cpp. * src/s/unixware.h (NEED_LIBW): Remove definition. * admin/CPP-DEFINES: Remove NEED_LIBW.
author Glenn Morris <rgm@gnu.org>
date Tue, 27 Apr 2010 01:09:01 -0700
parents 236318fbe135
children 947dd776616f
line wrap: on
line diff
--- a/configure.in	Tue Apr 27 00:38:05 2010 -0700
+++ b/configure.in	Tue Apr 27 01:09:01 2010 -0700
@@ -1833,6 +1833,7 @@
 
 X_TOOLKIT_TYPE=$USE_X_TOOLKIT
 
+LIBXTR6=
 if test "${USE_X_TOOLKIT}" != "none"; then
   AC_MSG_CHECKING(X11 toolkit version)
   AC_CACHE_VAL(emacs_cv_x11_toolkit_version_6,
@@ -1846,6 +1847,11 @@
     AC_MSG_RESULT(6 or newer)
     AC_DEFINE(HAVE_X11XTR6, 1,
 	      [Define to 1 if you have the X11R6 or newer version of Xt.])
+    LIBXTR6="-lSM -lICE"
+    case "$opsys" in
+      ## Use libw.a along with X11R6 Xt.
+      unixware) LIBXTR6="$LIBXTR6 -lw" ;;
+    esac
   else
     AC_MSG_RESULT(before 6)
   fi
@@ -1861,6 +1867,7 @@
   AC_CHECK_LIB(Xmu, XmuConvertStandardSelection)
   test $ac_cv_lib_Xmu_XmuConvertStandardSelection = no && LIBS="$OLDLIBS"
 fi
+AC_SUBST(LIBXTR6)
 
 # On Irix 6.5, at least, we need XShapeQueryExtension from -lXext for Xaw3D.
 if test "${HAVE_X11}" = "yes"; then