diff configure.in @ 57230:4408561037cf

* configure.in (HAVE_EXECSHIELD): Only define on x86. * configure: Rebuild.
author Jan Djärv <jan.h.d@swipnet.se>
date Sat, 25 Sep 2004 20:41:08 +0000
parents 6e40bed9e91e
children 6ce2eaa4905a e23928ac5a97
line wrap: on
line diff
--- a/configure.in	Sat Sep 25 20:39:13 2004 +0000
+++ b/configure.in	Sat Sep 25 20:41:08 2004 +0000
@@ -1288,13 +1288,22 @@
 
 dnl check if exec-shield is present.
 AC_CHECK_FILE(/proc/sys/kernel/exec-shield, emacs_cv_execshield=1,
-					    emacs_cv_execshield=0)
+                                            emacs_cv_execshield=0)
 if test "$emacs_cv_execshield" = 1; then
-   AC_PATH_PROG(SETARCH, setarch, no)
-   AC_SUBST(SETARCH)
-   if test "$setarch" != no; then
-     AC_DEFINE(HAVE_EXECSHIELD, 1, [Define to 1 if this OS has exec shield.])
-   fi
+  AC_PATH_PROG(SETARCH, setarch, no)
+  AC_SUBST(SETARCH)
+  if test "$setarch" != no && test "$machine" = "intel386"; then
+    AC_DEFINE(HAVE_EXECSHIELD, 1,
+    [Define to 1 if this OS has exec shield and we can handle it.])
+  else
+    case "`cat /proc/sys/kernel/exec-shield`" in
+      0) ;;
+      *)
+        AC_MSG_ERROR([Exec-shield is turned on.
+Emacs can not dump itself if exec-shield is turned on.
+See `etc/PROBLEMS' for further information.])
+    esac
+  fi
 fi
 
 #### Extract some information from the operating system and machine files.